Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Synchronisation of Scripts and Preferences Extensions

  • 5 replies
  • 7 have this problem
  • 24 views
  • Last reply by Kesta

more options

Hello everybody.

With Sync, we can synchronize our favorites, preferences, passwords and other ... But we can't synchronize our scripts (GreaseMonkey), or preferences of our extensions (accepted sites in the "NoScript" extension, for example).

So I was wondering if there was a way to synchronize not our preferences or our extensions, but the preferences of our extensions (GreaseMonkey, NoScript ...) ?

If not, maybe this request - if it hasn't already been asked - could it be reflections.


Thanks, and sorry for my english. Kesta.

Modified by Kesta

Chosen solution

Hi, something has changed.

Like I said, preference services.sync.prefs.sync.extensions.greasemonkey.sync.enabled was well true and nothing changed anything ...

But I found preference extensions.greasemonkey.sync.enabled and went to true, and there appeared three preferences : extensions.greasemonkey.sync.enabled.lastSync, extensions.greasemonkey.sync.enabled.lastSyncLocal and extensions.greasemonkey.sync.enabled.syncID.

Without the prefix services.sync.prefs.sync. ...

And since, the Scripts are included in the synchronization. However, no preferences extensions ("NoScript" for example). So, wonderful anyway.

Read this answer in context 👍 2

All Replies (5)

more options

If you want to sync additional prefs then you can create a corresponding sync pref yourself and set the value to true.

  • services.sync.prefs.sync.*

There are services.sync.prefs prefs related to set which prefs to sync and you can set the corresponding services.sync.prefs.sync.xxx pref to false to prevent syncing a pref.

more options

Thank you for your reply.

I'm trying to create booleans values ​​"services.sync.prefs.sync.extensions.prefs" & "services.sync.prefs.sync.scripts" and set to "true", but they doesn't work.

Answer too vague, and doesn't solve the problem.

For me, I think no solution yet really exists on this topic, I hope it will give ideas to developers ...

Modified by Kesta

more options

This pref is the "master" for turning Sync on / off for Greasemonkey.
services.sync.prefs.sync.extensions.greasemonkey.sync.enabled

services.sync.prefs.sync.extensions.greasemonkey.
will show you all the prefs for GM and Sync services.

GM 1.15 did not sync GM scripts for me, but none of my user scripts have an update or source URL - so that might be the problem for me.

I don't think that the sync for for GM User Scripts is completely enabled yet.
https://github.com/greasemonkey/greasemonkey/issues/1573
The latest issue (as of 2 months ago) was a conflict with the master password dialog showing up during browser start up, which appeared in GM 1.13.

more options

You need to append the full name of an existing pref as seen on the about:config page (i.e. prefix the pref with services.sync.prefs.sync.) to include this pref in syncing prefs.

more options

Chosen Solution

Hi, something has changed.

Like I said, preference services.sync.prefs.sync.extensions.greasemonkey.sync.enabled was well true and nothing changed anything ...

But I found preference extensions.greasemonkey.sync.enabled and went to true, and there appeared three preferences : extensions.greasemonkey.sync.enabled.lastSync, extensions.greasemonkey.sync.enabled.lastSyncLocal and extensions.greasemonkey.sync.enabled.syncID.

Without the prefix services.sync.prefs.sync. ...

And since, the Scripts are included in the synchronization. However, no preferences extensions ("NoScript" for example). So, wonderful anyway.

Modified by Kesta