Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Visited links don't turn purple?

  • 6 replies
  • 8 have this problem
  • 1522 views
  • Last reply by cor-el

more options

Hi, my visited links never turn purple. What's the problem? My Firefox is set to remember history, I don't see why it doesn't work. The only way to make it work is to uncheck "Allowed pages to use their colors instead of the ones selected above" but that makes every site look like crap. Other web browsers had this working, how can I make it work with Firefox without unchecking that option...?

All Replies (6)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

more options

Okay I did that, and it didn't work :(

more options

Did you try if this issue happens in Safe Mode? Don't select anything in the Safe Mode window, just use "Continue in Safe Mode.

Diagnose Firefox issues using Troubleshoot Mode

more options
more options

Okay now they turn purple but only on some sites. Not all. Why not..?

more options

Maybe those sites are opened in a (i)frame and in such cases you might not see the visited state.