Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Getting tabs across full width of window

  • 6 replies
  • 1 has this problem
  • 101 views
  • Last reply by wendiwoman2

more options

When I have a handful of tabs open, they start scrolling off-screen, despite the fact that there is plenty of room on the tab bar. In fact, tabs never seem to populate the right 50% of the tab bar. I have found plenty of advice about how to set minimum and maximum sizes for the tabs themselves, but that is not my problem. I want to be able to see all of my tabs when there is plenty of room to show them. Any way to solve this?

When I have a handful of tabs open, they start scrolling off-screen, despite the fact that there is plenty of room on the tab bar. In fact, tabs never seem to populate the right 50% of the tab bar. I have found plenty of advice about how to set minimum and maximum sizes for the tabs themselves, but that is not my problem. I want to be able to see all of my tabs when there is plenty of room to show them. Any way to solve this?

Chosen solution

Make sure you have width:100vw; property rules.

#TabsToolbar {
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}


See also this forum response for updated CSS code for Firefox 89+:

Read this answer in context 👍 0

All Replies (6)

more options

Hmm, does anything else seem to be using that empty space?

You can use the Customize panel to check whether there is some kind of spacer there (and remove it): Customize Firefox controls, buttons and toolbars.

Helpful?

more options

Hi jscher2000. Thanks for replying. I checked the customize panel, and there isn't anything there that I can see. Here's a screenshot showing my tab bar, with about ten open tabs.

Helpful?

more options

Hmm, moving the bar with userChrome.css? Perhaps there is a glitch with whatever maintains the width. Can you go back to the source of your rules and see whether there is an update for Firefox 96?

Helpful?

more options

I think you are the right track. I temporarily renamed the userChrome.css file, and the tab bar went to full width, but of course, above the other toolbars. I'll dig into the contents of that file. Thanks for your help.

Helpful?

more options

Chosen Solution

Make sure you have width:100vw; property rules.

#TabsToolbar {
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}


See also this forum response for updated CSS code for Firefox 89+:

Helpful?

more options

Cor-el... That was it! One quick edit, and all is now well. Thank you so much.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.