Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop Mozilla Foundation web page from opening?

  • 1 reply
  • 2 have this problem
  • 6 views
  • Last reply by cor-el

more options

Since updating to V33.1, when I open Firefox It opens a Mozilla Foundation web page in forground and my chosen homepage in second tab. How can I disable Mozilla Foundation page?

All Replies (1)

more options

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.