Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Secure Connection Failed" message on one Firefox browser, but not another

  • Nema odgovora
  • 0 ima ovaj problem
  • 4 views
more options

Hi! I have two Firefox accounts, one for work and one for personal use. I often have them running on the same computer at once (this does cause them to crash occasionally, but not often enough to be a problem). However, today I tried to log into a website where I regularly do freelance work and received this error code: "Error code: SSL_ERROR_PROTOCOL_VERSION_ALERT"

I would assume something was wrong with the website itself, however when I went to that same site on my other account, it loaded just fine. I've restarted my computer, restarted firefox, deleted cookies and caches and browser history, but still get the same message on my work account. Any idea how to fix this?

Thanks!

Hi! I have two Firefox accounts, one for work and one for personal use. I often have them running on the same computer at once (this does cause them to crash occasionally, but not often enough to be a problem). However, today I tried to log into a website where I regularly do freelance work and received this error code: "Error code: SSL_ERROR_PROTOCOL_VERSION_ALERT" I would assume something was wrong with the website itself, however when I went to that same site on my other account, it loaded just fine. I've restarted my computer, restarted firefox, deleted cookies and caches and browser history, but still get the same message on my work account. Any idea how to fix this? Thanks!

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.