On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Manage Extensions

  • 2 odgovori
  • 1 ima ovaj problem
  • 290 views
  • Posljednji odgovor poslao cor-el

more options

I am trying to manage Firefox extensions using a GPO using code below (Computer Configuration->Administrative Templates->Mozilla->Firefox->Extensions->Extension Management). The format below aligns with what is listed here "https://github.com/mozilla/policy-templates/blob/master/README.md#extensionsettings" and this is not working as expected. The goal is to only allow users to install the allowed extensions listed and everything else gets blocked. Please help?

Not sure if related but I also have "Extension Update" enabled

{
  "*": {
    "blocked_install_message": "Your admin has blocked adding this extension.",
    "install_sources": ["about:addons","https://addons.mozilla.org/"],
    "installation_mode": "blocked",
    "allowed_types": ["extension"]			
	},
    "abb@amazon.com": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/ublock-origin/latest.xpi"
		}
	},
    "ciscowebexstart1@cisco.com": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/cisco-webex-extension/latest.xpi"
		}
	},
    "{bda65ea0-2465-43b6-9b66-d396988c24aa}": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/google-hangout/latest.xpi"
		}
	},
		"linkedinConverted@firefox-extension": {
        "installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/linkedin-notifications/latest.xpi"
      }
	},
    "{7bc53591-5218-45a0-b572-4366979097fd}": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/markdown-diagrams/latest.xpi"
      }
	},
    "queryamoid@kaply.com": {
		"installation_mode": "allowed",
		"install_url": "https://raw.githubusercontent.com/mkaply/queryamoid/main/updates.json"
      }
	},
    "jid1-93WyvpgvxzGATw@jetpack": {
        "installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/to-google-translate/latest.xpi"
      }
}
I am trying to manage Firefox extensions using a GPO using code below (Computer Configuration->Administrative Templates->Mozilla->Firefox->Extensions->Extension Management). The format below aligns with what is listed here "https://github.com/mozilla/policy-templates/blob/master/README.md#extensionsettings" and this is not working as expected. The goal is to only allow users to install the allowed extensions listed and everything else gets blocked. Please help? Not sure if related but I also have "Extension Update" enabled <pre><nowiki>{ "*": { "blocked_install_message": "Your admin has blocked adding this extension.", "install_sources": ["about:addons","https://addons.mozilla.org/"], "installation_mode": "blocked", "allowed_types": ["extension"] }, "abb@amazon.com": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/ublock-origin/latest.xpi" } }, "ciscowebexstart1@cisco.com": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/cisco-webex-extension/latest.xpi" } }, "{bda65ea0-2465-43b6-9b66-d396988c24aa}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/google-hangout/latest.xpi" } }, "linkedinConverted@firefox-extension": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/linkedin-notifications/latest.xpi" } }, "{7bc53591-5218-45a0-b572-4366979097fd}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/markdown-diagrams/latest.xpi" } }, "queryamoid@kaply.com": { "installation_mode": "allowed", "install_url": "https://raw.githubusercontent.com/mkaply/queryamoid/main/updates.json" } }, "jid1-93WyvpgvxzGATw@jetpack": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/to-google-translate/latest.xpi" } }</nowiki></pre>

Izmjenjeno od strane cor-el

Izabrano rješenje

Your code has a a lot of extra lines with a closing '}'. You can try this code instead.

Software\Policies\Mozilla\Firefox\ExtensionSettings (REG_MULTI_SZ) =
{
 "*": {
    "blocked_install_message": "Your admin has blocked adding this extension.",
    "install_sources": ["about:addons","https://addons.mozilla.org/"],
    "installation_mode": "blocked",
    "allowed_types": ["extension"]			
	},
  "abb@amazon.com": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/ublock-origin/latest.xpi"
	},
  "ciscowebexstart1@cisco.com": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/cisco-webex-extension/latest.xpi"
	},
  "{bda65ea0-2465-43b6-9b66-d396988c24aa}": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/google-hangout/latest.xpi"
	},
	"linkedinConverted@firefox-extension": {
        "installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/linkedin-notifications/latest.xpi"
	},
  "{7bc53591-5218-45a0-b572-4366979097fd}": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/markdown-diagrams/latest.xpi"
	},
  "queryamoid@kaply.com": {
		"installation_mode": "allowed",
		"install_url": "https://raw.githubusercontent.com/mkaply/queryamoid/main/updates.json"
	},
  "jid1-93WyvpgvxzGATw@jetpack": {
        "installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/to-google-translate/latest.xpi"
 }
}

Pročitajte ovaj odgovor sa objašnjenjem 👍 1

All Replies (2)

more options

Odabrano rješenje

Your code has a a lot of extra lines with a closing '}'. You can try this code instead.

Software\Policies\Mozilla\Firefox\ExtensionSettings (REG_MULTI_SZ) =
{
 "*": {
    "blocked_install_message": "Your admin has blocked adding this extension.",
    "install_sources": ["about:addons","https://addons.mozilla.org/"],
    "installation_mode": "blocked",
    "allowed_types": ["extension"]			
	},
  "abb@amazon.com": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/ublock-origin/latest.xpi"
	},
  "ciscowebexstart1@cisco.com": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/cisco-webex-extension/latest.xpi"
	},
  "{bda65ea0-2465-43b6-9b66-d396988c24aa}": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/google-hangout/latest.xpi"
	},
	"linkedinConverted@firefox-extension": {
        "installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/linkedin-notifications/latest.xpi"
	},
  "{7bc53591-5218-45a0-b572-4366979097fd}": {
		"installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/markdown-diagrams/latest.xpi"
	},
  "queryamoid@kaply.com": {
		"installation_mode": "allowed",
		"install_url": "https://raw.githubusercontent.com/mkaply/queryamoid/main/updates.json"
	},
  "jid1-93WyvpgvxzGATw@jetpack": {
        "installation_mode": "allowed",
        "install_url": "https://addons.mozilla.org/firefox/downloads/latest/to-google-translate/latest.xpi"
 }
}

more options

Moving thread to Firefox for Enterprise.