X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Firefox stopped remembering where to save downloads by site

Objavljeno

Before, Firefox would remember where I had saved a file based on the domain. So it would remember that things I download from my banking sites go in the user/finance folder, and things I downloaded from board game sites go in the user/games folder. It stopped doing that and now it defaults to whatever the last used download location was, regardless of the download domain.

How can I get it to revert to the previous behavior? It was very handy for it to remember that a file downloaded from the site http://foo.com/ went in the user/foo folder...

Before, Firefox would remember where I had saved a file based on the domain. So it would remember that things I download from my banking sites go in the user/finance folder, and things I downloaded from board game sites go in the user/games folder. It stopped doing that and now it defaults to whatever the last used download location was, regardless of the download domain. How can I get it to revert to the previous behavior? It was very handy for it to remember that a file downloaded from the site http://foo.com/ went in the user/foo folder...
Citiraj

Dodatni detalji o sistemu

Instalirani priključci

1Password X, Browser Fairy, Cookie AutoDelete, Decnetraleyes, F.B Purity, Facebook Container, Fakespot Review Checker, Firefox Multi-Account Containers, Google search link fix, Honey, HTTPS Everywhere, Privacy Badger, ReviewMeta, Terms of Service, Toolkit for YNAB, uBlock Origin, Unpaywall.

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:75.0) Gecko/20100101 Firefox/75.0

Više informacija

McCoy
  • Top 10 Contributor
633 rješenja 6051 odgovora
Objavljeno

Hello Chris Schaffer,

Would you try this please :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

browser.download.useDownloadDir and set its value to false (default = "true")

Then type in the search bar and look for the preference :

browser.download.folderList and make sure that its value is not
set to "2" - if it is : change it to 1 (= default).

If you had to change a value, then close and restart Firefox.

Any difference ?

Hello Chris Schaffer, Would you try this please : Type in the address bar '''about:config''' and press Enter (ignore the warning) Type in the search bar and look for the preference : '''browser.download.useDownloadDir''' and set its value to '''false''' (default = "true") Then type in the search bar and look for the preference : '''browser.download.folderList ''' and make sure that its value is not <BR>set to "2" - if it is : change it to '''1''' (= default). If you had to change a value, then close and restart Firefox. Any difference ?
Je li vam ovo pomoglo? 0
Citiraj

Vlasnik pitanja

useDownloadDir was already set to false and folderList was set to 1.

I went ahead and changed it to True / 2, restarted, then set it back to False / 1.

Unfortunately, it's still not working correctly.

useDownloadDir was already set to false and folderList was set to 1. I went ahead and changed it to True / 2, restarted, then set it back to False / 1. Unfortunately, it's still not working correctly.
Je li vam ovo pomoglo?
Citiraj
McCoy
  • Top 10 Contributor
633 rješenja 6051 odgovora
Objavljeno

Bummer !

Would you try to create this boolean preference :

browser.download.lastDir.savePerSite and set its value to false

(then close and restart Firefox)

Any luck ?

Bummer ! Would you try to create this boolean preference : '''browser.download.lastDir.savePerSite ''' and set its value to '''false''' (then close and restart Firefox) Any luck ?
Je li vam ovo pomoglo? 0
Citiraj
cor-el
  • Top 10 Contributor
  • Moderator
17865 rješenja 161655 odgovora
Objavljeno

Korisan odgovor

Does this still work in the current Firefox 74.0 release since you posted with Firefox 75 Beta/DE ?

You aren't using Private Browsing mode or have enabled "Resist Fingerprinting" ?

Does this still work in the current Firefox 74.0 release since you posted with Firefox 75 Beta/DE ? You aren't using Private Browsing mode or have enabled "Resist Fingerprinting" ?
Je li vam ovo pomoglo? 1
Citiraj

Vlasnik pitanja

browser.download.lastDir.savePerSite was already false. Changing it to true didn't help, nor did changing it back to false (restarting Firefox each time).

I'm not using Private Browsing.

Privacy.resistFingerprinting is set to false.

I'll investigate if downgrading to 74.0 helps.

browser.download.lastDir.savePerSite was already false. Changing it to true didn't help, nor did changing it back to false (restarting Firefox each time). I'm not using Private Browsing. Privacy.resistFingerprinting is set to false. I'll investigate if downgrading to 74.0 helps.
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Downgrading to 74.0 didn't help either

Downgrading to 74.0 didn't help either
Je li vam ovo pomoglo?
Citiraj
McCoy
  • Top 10 Contributor
633 rješenja 6051 odgovora
Objavljeno

I just read a very, very long thread from back in 2011, where numerous people had the same problem.

For some what has been suggested here did the trick; for others nothing seemed to work.

As nothing works for you either, maybe you'd like to give this add-on a try :

https://addons.mozilla.org/en-US/firefox/addon/downthemall/

Maybe this doesn't even come close to doing what you want, but it's worth a try though .....

I just read a very, very long thread from back in 2011, where numerous people had the same problem. For some what has been suggested here did the trick; for others nothing seemed to work. As nothing works for you either, maybe you'd like to give this add-on a try : https://addons.mozilla.org/en-US/firefox/addon/downthemall/ Maybe this doesn't even come close to doing what you want, but it's worth a try though .....
Je li vam ovo pomoglo?
Citiraj
Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.