Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am not able to install an addon and receiving the following Error. "This add-on is not compatible with your version of Firefox." who can i fix it?

  • 1 odgovor
  • 1 ima ovaj problem
  • 1 view
  • Posljednji odgovor poslao Happy112

more options

I am not able to install an addon and receiving the following Error. "This add-on is not compatible with your version of Firefox." who can i fix it?

For details please check the Screen shot.

https://imgur.com/a/WS7TV

Thanks

I am not able to install an addon and receiving the following Error. "This add-on is not compatible with your version of Firefox." who can i fix it? For details please check the Screen shot. https://imgur.com/a/WS7TV Thanks

All Replies (1)

more options

Hi  !

The add-on is not compatible with Firefox version 57+ because the developers need to migrate it to Webextensions.

You could try and contact them about it :

https://browsec.com/en/contact_us