Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I keep getting this message? "firefox is installing components needed to play audio or video on this page"

  • 5 odgovori
  • 3 ima ovaj problem
  • 2 views
  • Posljednji odgovor poslao Majordis

more options

Whenever I try to play a video from netflix, Amazon prime, or almost anything else, it won't plat & I get this message! All works fine with Internet Explorer :)

Whenever I try to play a video from netflix, Amazon prime, or almost anything else, it won't plat & I get this message! All works fine with Internet Explorer :)

All Replies (5)

more options

It sounds like the content decryption module plugin has not been installed on your Firefox or has not been activated.

Please navigate to the Add-on Manager in Firefox via the menu or by typing about:addons in the Firefox address bar. Select Plugins from the sidebar. Look for any plugin that says Content Decryption Module (usually Widevine by Google or Primetime by Adobe). Make note of the plugin status on the right hand side. At least on of these should be set to Always activate or Ask to activate. Most users have Widevine set to Always activate. Restart Firefox after activating one of these and try to play the video again.

If you continue to experience issues, try activating the other plugin.

more options

In the Plugins Manager, under Widevine, it just saya "Widevine Content Decryption Module provided by Google will be installed shortly". It's been saying this for days!.

 The other one "Primetime Content Decryption Module" is also there, but it seems to be working..I guess...No error messages
  Thanks..Majordis
more options

hi Majordis, have you set firefox to update automatically? which security software is running on your device?

more options

You can try manually installing Widevine from the website for Firefox. See if that solves the issue.

more options

philipp said

hi Majordis, have you set firefox to update automatically? which security software is running on your device?