Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

i need firefox always show sites in desktop view , how can i do this?

  • 6 odgovori
  • 3 ima ovaj problem
  • 4826 views
  • Posljednji odgovor poslao MaGeD Homaid

more options

I need to use mozilla firefox on my tablet because i'm using it on my personal laptop and it's the best web browser for me But on my tablet i need fire fox to be always show websites in desktop layot (desktop view) and there is no option to do that Every time I launch mozilla i have to go to options then tick the request desktop site , I need this option to be always enabled and there is no action to do this. So please fix this option or give me a method to apply it to be always in desktop view

Izmjenjeno od strane MaGeD Homaid

All Replies (6)

more options

Please see the next post for a better workaround!


When you request desktop view, Firefox re-requests the page but identifies the browser differently:

Firefox for Android on Tablet (your Android version may vary):

Mozilla/5.0 (Android 6.0; Tablet; rv:45.0) Gecko/45.0 Firefox/45.0

Desktop View:

Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0

If you want your Firefox for Android to ALWAYS use the Linux identification, you can create a new preference. This completely bypasses the menu item. Here's how:

(1) Select and copy the Linux useragent string above

(2) Open a new tab to about:config (type about:config in the Awesomebar and tap the go arrow or tap Enter).

You may want to bookmark this for easier future access.

(3) Tap the large "+" button to the left of the search box to add a new setting

(A) The name of the preference should be general.useragent.override -- beware that autocorrect may insert a space between user and agent, you will need to delete that space

(B) On the right side, tap Boolean and in the popup change it to String

(C) Long press in the space for the value and Paste the Linux useragent string

(D) Then click Create (if you are too slow, it may clear and you might have to start again)

You can test on this page (the useragent string is displayed in red):

https://jeffersonscher.com/res/jstest.php

Izmjenjeno od strane jscher2000

more options

Odabrano rješenje

more options

jscher2000 said

Please see the next post for a better workaround!

When you request desktop view, Firefox re-requests the page but identifies the browser differently:

Firefox for Android on Tablet (your Android version may vary):

Mozilla/5.0 (Android 6.0; Tablet; rv:45.0) Gecko/45.0 Firefox/45.0

Desktop View:

Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0

If you want your Firefox for Android to ALWAYS use the Linux identification, you can create a new preference. This completely bypasses the menu item. Here's how:

(1) Select and copy the Linux useragent string above

(2) Open a new tab to about:config (type about:config in the Awesomebar and tap the go arrow or tap Enter).

You may want to bookmark this for easier future access.

(3) Tap the large "+" button to the left of the search box to add a new setting

(A) The name of the preference should be general.useragent.override -- beware that autocorrect may insert a space between user and agent, you will need to delete that space

(B) On the right side, tap Boolean and in the popup change it to String

(C) Long press in the space for the value and Paste the Linux useragent string

(D) Then click Create (if you are too slow, it may clear and you might have to start again)

You can test on this page (the useragent string is displayed in red):

https://jeffersonscher.com/res/jstest.php

Thank you a lot for your support and your reply fixed my brobleme brother Thank you.. Best wishes

more options

kbrosnan said

Or just use this extension https://addons.mozilla.org/en-US/android/addon/desktop-by-default/

Brother kbrosnan thank you for this extension , the post of jscher2000 was helpful too and the both fixed my issue . With my best wishes. MaGeD

Izmjenjeno od strane MaGeD Homaid

more options

I think the extension is the better solution because you have the ability to switch individual pages BACK to mobile view when the desktop view is unworkable. Can you mark that post as the solution? I think there may be a link on the right side when you view it:

https://support.mozilla.org/questions/1114055#answer-855402

more options

Ok but i can switch back to mobile view when i delete the preference Then re make it , but as you like i will mark it as the solution