Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox used to be able to open my library search, but now it can't Internet explorer can

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by receive

more options

When opening my public library account and searching for a book, Firefox now opens a weird back door type of search screen that is hard to read, it used to work fine. Internet Explorer opens the normal search screen. I have screen shots of the two searches if this is helpful.

When opening my public library account and searching for a book, Firefox now opens a weird back door type of search screen that is hard to read, it used to work fine. Internet Explorer opens the normal search screen. I have screen shots of the two searches if this is helpful.

Chosen solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

2. If needed, delete the site's cookies here:

right-click the page, choose View Page Info > Security > "View Cookies"

If that doesn't help, you might try using Firefox's Safe Mode as a diagnostic tool to see whether one of your add-ons could be at fault.

First, I recommend backing up your Firefox settings in case something goes wrong. See Backing up your information. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, try starting Firefox in Firefox Safe Mode. Be careful not to "reset" anything permanently if you didn't back up.

Does that fix it?

---

I should add that the site seemed to work normally for me, but I can only test logged out and the logged in behavior might be different.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

2. If needed, delete the site's cookies here:

right-click the page, choose View Page Info > Security > "View Cookies"

If that doesn't help, you might try using Firefox's Safe Mode as a diagnostic tool to see whether one of your add-ons could be at fault.

First, I recommend backing up your Firefox settings in case something goes wrong. See Backing up your information. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, try starting Firefox in Firefox Safe Mode. Be careful not to "reset" anything permanently if you didn't back up.

Does that fix it?

---

I should add that the site seemed to work normally for me, but I can only test logged out and the logged in behavior might be different.

Modified by jscher2000 - Support Volunteer

more options

I got as far as clearing Firefox's Cache but couldn't figure out how to delete the cookies. I tried the site anyway and it now seems to work normally. Thank you jscher2000, I'm impressed.