Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox open 5 browers when started?

  • 4 replies
  • 1 has this problem
  • 1 view
  • Last reply by TyDraniu

more options

When I open Firefox 5-6 browsers are opened in "task manager" they take up 30% of memory; If I try to close the "extra browsers" all close. Firefox only shows a single tab on my screen.

All Replies (4)

more options

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

Tried your "refresh" suggestion, no difference.

more options

after refresh, no changes were observed, same situation continues. It seems odd that so many browsers open and use so much memory with no discernible benefit. Is there a fix?

more options

It's processes, not browsers. You can actually lower the number of processes, it's explained here: Firefox's performance settings.