Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Firefox constantly hangs/freezes on Mac OS

  • 1 reply
  • 2 have this problem
  • 3485 views
  • آخر ردّ كتبه AliceWyman

more options

Duplicate of /questions/976177 Firefox constantly freezes on my Mac, although I've installed the latest version and tried all suggested fixes - without success. (locking)]. aw

I'm using an iMac, system 10.9. My problem is that Firefox 25 launches correctly and displays Google (which I've chosen as my start page), but that whenever I go to to a web page, Firefox hangs/freezes. For instance I can go to the BBC site, but once there FF hangs/freezes. Then it won't respond to any clicking or commands, and I have to force-quit.

Firefox has even done this in the Mozilla help pages !

I've tried several other "fixes", all to no avail. Besides, a fix or workaround should not be necessary -it isn't with other browsers. And I've trashed FF more than once, doing a clean reinstall (yes, I've been careful to also trash any associated file, using Appcleaner).

The problem has been there in every version of FF I've tried in the last four years. Version 3.5 worked well but all the subsequent versions have caused this problem. Why ?

As I said, other browsers work, and do so without needing any "fixes". So they work, and so does my computer. The problem is with Firefox, that obviously has a flaw somewhere. I'd love to know what it is.

Modified by AliceWyman

All Replies (1)

more options

My suggestion would be to reset Firefox as explained in the Refresh Firefox - reset add-ons and settings article if you haven't tried that already. Other suggestions for Firefox hangs are in the Firefox hangs or is not responding - How to fix article.

I see that this is a continuation of your previous thread,

/questions/976177 Firefox constantly freezes on my Mac, although I've installed the latest version and tried all suggested fixes - without success.

I've tagged that thread "escalate". You should post a reply in the other thread, saying whether you tried a Firefox Reset and if it made any difference.

I'm going to close this question since it's essentially a duplicate of the previous one, where you last posted on November 8, 2013.