ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address Bar Not Searching Properly

  • 3 ردود
  • 29 have this problem
  • 469 views
  • آخر ردّ كتبه Helper7677

more options

This started occuring after updating to FF4.

Example -

Typing "yahoo email" into address bar took me right to yahoo's email sign-in page.

Now, after updating, typing "yahoo email" into address bar results in a regular google search, and I have to click on the yahoo email link.

Before 4.0, type "imdb" into address bar, and imdb.com opened right up.

Now, type "imdb" into address bar, and regular search instead, have to click on imdb link.

All precise keyword-specific searches that directly match a pre-existing url (IMDb for IMDb.com, Yahoo News for news.yahoo.com, Volokh for volokh.com, etc) no longer go directly to the site, but result in a regular google search with results, requiring that extra click on the link.

Glitch? Can this be fixed through about:config?

الحل المُختار

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site
  • To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.
    1. Type about:config into the location bar and press the Enter key
    2. If you see a warning, zccept it (promise to be careful)
    3. A list of preferences will open
    4. Filter = keyword.URL
    5. Double-click on that preference in the lower pane
    6. A small window will appear; copy the line below and paste into the box in that small window (or type it into the box in that window exactly as shown below):
  • See:
Read this answer in context 👍 11

All Replies (3)

more options

الحل المُختار

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site
  • To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.
    1. Type about:config into the location bar and press the Enter key
    2. If you see a warning, zccept it (promise to be careful)
    3. A list of preferences will open
    4. Filter = keyword.URL
    5. Double-click on that preference in the lower pane
    6. A small window will appear; copy the line below and paste into the box in that small window (or type it into the box in that window exactly as shown below):
  • See:
more options

Thank you very much!

more options

You are welcome.

So that other users can find answers that have worked, please take a couple of minutes to return to the forum, sign in and click "Solved" next to the answer that solved your problem. Thanks.