ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Words are unreadable.

  • 6 ردود
  • 0 have this problem
  • 8 views
  • آخر ردّ كتبه zeroknight

more options

I have not been able to get this fixed for weeks now. What good is a browser if you cant read what is on the screen? Words are all gobbleygook.

I have not been able to get this fixed for weeks now. What good is a browser if you cant read what is on the screen? Words are all gobbleygook.
Attached screenshots

Modified by NoahSUMO

All Replies (6)

more options

Hi, that looks like a screenshot from your Mac. This question is currently under iPhone/iPad, so I'll flag it to move over to "desktop" Firefox.

Meanwhile, that looks like a font problem. As a Windows person, I can't give you any first-hand guidance on fixing font problems in Firefox for Mac, but hopefully a Mac user will step in.

Helpful?

more options

Issues with a weird looking font or missing glyphs can be caused by a problem with a specific font and you need to identify this font and fix this. You may find that it can be resolved by finding and removing duplicate fonts installed in the local ~/Library/Fonts folder, that are conflicting with standard system fonts.

You can check in Font Book for font issues like corrupted and duplicate fonts. Note that you should be careful about disabling "Allow pages to choose their own fonts, instead of your selections above" as this will cause issues with iconic fonts used by webpages to display small icons (you may see text labels instead of icons).

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the down arrow at the right end.

In Firefox 119 Fingerprinting protection has been added to Enhanced Tracking Protection in Strict/Custom mode (Suspected fingerprinters) what affects accessing local fonts. To include user installed fonts, modify this pref on the about:config page: privacy.fingerprintingProtection.overrides => -FontVisibilityBaseSystem,-FontVisibilityLangPack You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

Helpful?

more options

Are you by any chance from the Netherlands? I was able to extract the text from the image & Google Translate reported the language as Frisian, a dialect from the Netherlands. So somehow you enabled that inside Firefox's settings or you're using a localization/language setting on your Windows OS settings to set this language system wide. But it sounds like its just affecting Firefox so far.

Is every website you visit being translated to Frisian/gobbleygook as well? If so, I would check your addons next. Trying disabling them. Maybe one of them is doing this. I would really like to know what addon has the power to do that.

To disable your addons: https://support.mozilla.org/en-US/kb/disable-or-remove-add-ons#w_disabling-and-removing-extensions

Helpful?

more options

See this relevant bug about such issues on Mac:

  • 1803406 - [macOS] Text rendering issues when users have multiple fonts which internally use the same name, and the OS chooses differently among them for different Firefox processes

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

more options

i am not from the netherlands and this is Mac OS not windows. this just started with the last Firefox update. been working fine for years. have not added, changed or modified any fonts on the Macbook.

Helpful?

more options

These reports coincided with the macOS Sonoma update which likely introduced new fonts, causing there to be duplicates and conflicts with older fonts (Bug 1803406).

Workarounds include:

  • Uninstall old or unused fonts.
  • Identify the garbled font with devtools inspector (Cmd+Opt+C) and uninstall it.
  • Go to about:config and change gfx.e10s.font-list.shared and gfx.font-list-omt.enabled to false then restart the browser.

Helpful?

اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.