Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Nvidia video super resolution not working after enabling gfx.webrender.super-resolution.nvidia

  • 7 ردود
  • 2 have this problem
  • 416 views
  • آخر ردّ كتبه Piterk

more options

Firefox 114 introduced hidden support for nvidia video super resolution. In about:config you can enable preference gfx.webrender.super-resolution.nvidia to make it work. However I see 0 difference on all videos on all pages. I have everything in nvidia control panel set correctly (VSR enabled and set to 4/4 quality).

Tried to find more info online and someone on reddit complained that it worked before but it stopped working with latest firefox beta (probably before final 114 release): https://www.reddit.com/r/firefox/comments/13duluz/nvidia_video_super_resolution_comes_to_firefox/

I tried using logic too - if this pref is related to webrenderer in its name maybe it is not working because I am not using webrenderer? However I checked about:support and in section graphics->composition I have "webrenderer" so it seems I am using it, but its VSR feature is not working at all.

Firefox 114 introduced '''hidden support for nvidia video super resolution'''. In about:config you can enable preference '''gfx.webrender.super-resolution.nvidia '''to make it work. However I see 0 difference on all videos on all pages. I have everything in nvidia control panel set correctly (VSR enabled and set to 4/4 quality). Tried to find more info online and someone on reddit complained that it worked before but it stopped working with latest firefox beta (probably before final 114 release): https://www.reddit.com/r/firefox/comments/13duluz/nvidia_video_super_resolution_comes_to_firefox/ I tried using logic too - if this pref is related to webrenderer in its name maybe it is not working because I am not using webrenderer? However I checked about:support and in section graphics->composition I have "webrenderer" so it seems I am using it, but its VSR feature is not working at all.
Attached screenshots

الحل المُختار

Can you report it on bugzilla.mozilla.org? Thanks.

Read this answer in context 👍 0

All Replies (7)

more options

الحل المُختار

Can you report it on bugzilla.mozilla.org? Thanks.

Modified by TyDraniu

more options

Could you open the about:support page, go to section GPU 1 and read the Vendor ID (ID dostawcy)? Thanks.

more options

It is 0x10de - nvidia Device id is 0x2484 (RTX 3070)

Modified by Piterk

more options

Well it looks like it was very easy to fix. https://bugzilla.mozilla.org/show_bug.cgi?id=1838781#c3

There was error in code, they had to replace

enabled ?  0 : 1u};

with

enabled ? 1u : 0};

It took 15 days to resolve this and fix will be published in firefox 116 on 1st August if everything goes well. https://whattrainisitnow.com/calendar/

1 little mistake and 2 months of delay for this feature. Ugh!

more options

Please confirm that it works for you and set this question as Solved.

more options

Well, today on firefox 116 I can confirm it is finally working! First image is off, 2nd one is on https://imgur.com/a/wXDeUTn