ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox browser search engine changes to "Amazon"

  • 5 ردود
  • 0 have this problem
  • 1 view
  • آخر ردّ كتبه george197

more options

For last few weeks something keeps changing my default browser from DuckDuckGo to Amazon and I have no idea how or why. Is there a way to lock the default so Amazon can't change it?

For last few weeks something keeps changing my default browser from DuckDuckGo to Amazon and I have no idea how or why. Is there a way to lock the default so Amazon can't change it?

All Replies (5)

more options

Amazon doesn't have a Browser so not sure what's happening here. Only way to set the page is to set a homepage load that will keep as the homepage.

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

more options

The Amazon extension is installed whether we like it or not. Try removing it if it is shown on the Search page in Settings. I still have it but it isn't shown on the Search page and DDG stays as my default.

https://support.mozilla.org/en-US/kb/add-or-remove-search-engine-firefox

more options

Terry,

Thank you for the idea to remove Amazon Search Engine from the list. I'll give that a try but not the true problem. Perhaps once or twice a day, something keeps changing my "Default" search engine from "DuckDuckGo" to "Amazon".

I sort of like having "Amazon" as one of the drop down options but not my default. Most of my searches are for information not products and DuckDuckGo provides more data oriented pages and less product advertisements.

more options

george197, I have experienced the unexpected default search engine change before now. In my case I think it was due to my inadvertently pressing ctrl plus up / down arrow, when in the Firefox search box.

I use ctrl plus left / right arrow frequently when editing search terms, so I assume that on those occasions I must have pressed the wrong arrow.

Fortunately, it was easy to switch back to my preferred engine using the same ctrl+up / down shortcuts.

Is it possible that something like this is the explanation here?

Modified by TechHorse

more options

Thank you for the thought. It is possible that I inadvertently hit "ctrl" key, old age hand tremor and next to the "shift" key but I never use the arrows. Other problem is this just started happening a few weeks ago and I've been using Mozilla since my UNIX days in late 1980's. Perhaps bug in an automatic update, I visited a nefarious WEB page, or Amazon trying to be helpful.

Interesting note, the earlier suggestion to remove "Amazon" search from the available search options has resolved the problem for 3 days now. None of the other available search engines has replaced the default engine as I'd expect to see if it was keyboard tremor.