ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove phantom bookmark "Amazon.com" from search suggestions

  • 4 ردود
  • 0 have this problem
  • 29 views
  • آخر ردّ كتبه warp101

more options

Greetings

When I enter the first few digits of "amazon" the first suggestion is always "amazon.com". That would be nice were it not for the fact that, as a European, I don't have that much use for prices in dollars and imperial measurements. I have bookmarked "amazon.de" but due to alphabetical order .com always comes first. Naturally, I have tried to purge "amazon.com" from my bookmarks but I have been unable to find anything that I could delete. Thus, I am wondering whether anyone might know how this issue might be tackled and I would be much obliged if anyone could help.

Best Regards Felix

Greetings When I enter the first few digits of "amazon" the first suggestion is always "amazon.com". That would be nice were it not for the fact that, as a European, I don't have that much use for prices in dollars and imperial measurements. I have bookmarked "amazon.de" but due to alphabetical order .com always comes first. Naturally, I have tried to purge "amazon.com" from my bookmarks but I have been unable to find anything that I could delete. Thus, I am wondering whether anyone might know how this issue might be tackled and I would be much obliged if anyone could help. Best Regards Felix

الحل المُختار

I solved it. Turns out I had bookmarked one link from a US blogger that led to a specific item ("https://www.amazon.com/something/some_other_thing") and this led to Firefox showing me the start page of Amazon as a suggestion without indicating why. To be honest I find this behaviour a bit unintuitive.

Anyways, thanks for your help!

Read this answer in context 👍 0

All Replies (5)

more options

You can try to open an amazon.com page in a tab to get a fresh history entry and use "Forget About This Site".

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose, make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website, data for that website will be saved once again.

more options

Seems like a useful feature I didn't know about. Thank you for notifying me. Unfortunately, I still get the suggestion "amazon.com" even after "forgetting" it.

more options

Is this suggestion a bookmark (i.e. it has a star attached) ?

If that is the case then you need to search your bookmarks. If there is a pin attached then check the Firefox Home page (about:newtab).

more options

Thanks for your reply. There is neither a star nor a pin attached to the favicon. I called it a "phantom bookmark" because it persists between sessions (i. e. when I close and restart Firefox it's still there). I have set the browsing history to be cleared whenever I quit Firefox and I have unpinned everything amazon-related from about:newtab so I haven't got any idea where this suggestion comes from.

more options

الحل المُختار

I solved it. Turns out I had bookmarked one link from a US blogger that led to a specific item ("https://www.amazon.com/something/some_other_thing") and this led to Firefox showing me the start page of Amazon as a suggestion without indicating why. To be honest I find this behaviour a bit unintuitive.

Anyways, thanks for your help!

Modified by warp101