ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to play Twitter/Reddit/Facebook Video and GIFs on Firefox 99.0.1 (64-bit)

  • 4 ردود
  • 1 has this problem
  • 64 views
  • آخر ردّ كتبه Bhanu Magotra

more options

I have fedora 36 Linux on my laptop and I have installed Firefox from the software store. The version in Help>About>About Firefox shows 99.0.1 (64-bit).

I am able to play videos on Youtube but no video or GIF is playing on Twitter/Reddit/Facebook.

I have installed media codecs as per this fedora help

My autoplay setting look like as per the attached image. I do not have any extensions except Bitwarden on Firefox.

I also tried playing videos on Firefox 100 by downloading it directly from firefox website but faced the same issue.

I have fedora 36 Linux on my laptop and I have installed Firefox from the software store. The version in Help>About>About Firefox shows 99.0.1 (64-bit). I am able to play videos on Youtube but no video or GIF is playing on Twitter/Reddit/Facebook. I have installed media codecs as per this [https://docs.fedoraproject.org/en-US/quick-docs/assembly_installing-plugins-for-playing-movies-and-music/ fedora help] My autoplay setting look like as per the attached image. I do not have any extensions except Bitwarden on Firefox. I also tried playing videos on Firefox 100 by downloading it directly from firefox website but faced the same issue.
Attached screenshots

الحل المُختار

The issue got resolved after upgrading to Firefox 100. The autoplay settings are attached.

Read this answer in context 👍 0

All Replies (4)

more options

Make sure you have the latest FFmpeg and libavcodec packages installed.

Helpful?

more options

Hi, Thanks for suggesting. FFmpeg was already at latest version. I also installed "FFmpeg-devel" package. However, this did not solve my problem. I am attaching the results from terminal command "ffmpeg -version" below :

$ ffmpeg -version ffmpeg version 5.0.1 Copyright (c) 2000-2022 the FFmpeg developers libavutil 57. 17.100 / 57. 17.100 libavcodec 59. 18.100 / 59. 18.100 libavformat 59. 16.100 / 59. 16.100 libavdevice 59. 4.100 / 59. 4.100 libavfilter 8. 24.100 / 8. 24.100 libswscale 6. 4.100 / 6. 4.100 libswresample 4. 3.100 / 4. 3.100 libpostproc 56. 3.100 / 56. 3.100

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click the shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Modified by cor-el

Helpful?

more options

الحل المُختار

The issue got resolved after upgrading to Firefox 100. The autoplay settings are attached.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.