ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not rendering - profile

  • 6 ردود
  • 1 has this problem
  • 19 views
  • آخر ردّ كتبه killuax

more options

Hello, recently i installed Kubuntu 20.04 (KDE Plasma 5.18.8). I have this problem where firefox (version 100) is not rendering the window and i think it's the profile folder.

First i was thinking on the graphics. i have installed 'nvidia-driver-510'. I tried this Solution with no luck.

I have:

  • Intel HD Graphics 620
  • Nvidia MX130

I tried :

  • Renaming the folder '.mozilla' to '.mozilla_bak' works perfectly but i have to do this every startup, and firefox creates a new profile where i have to logon in every platform i use.
  • Downloading 'firefox-100.0.1.tar.bz2', it's the same, works fine with a new profile.

This lead me to the profile folder, running './firefox --profile ~/.mozilla/firefox/<profile_folder>' it's the same, not rendering the entire window. I dont know why my profile is causing this problem, i only use three addons: AdBlock, BetterTTV and FoxyProxy, i have the same problem even if i dont have these installed.

Hello, recently i installed Kubuntu 20.04 (KDE Plasma 5.18.8). I have this problem where firefox (version 100) is not rendering the window and i think it's the profile folder. First i was thinking on the graphics. i have installed 'nvidia-driver-510'. I tried this [https://askubuntu.com/questions/1380600/firefox-occasionally-not-rendering-its-own-window-when-opened Solution] with no luck. I have: * Intel HD Graphics 620 * Nvidia MX130 I tried : * Renaming the folder '.mozilla' to '.mozilla_bak' works perfectly but i have to do this every startup, and firefox creates a new profile where i have to logon in every platform i use. * Downloading 'firefox-100.0.1.tar.bz2', it's the same, works fine with a new profile. This lead me to the profile folder, running './firefox --profile ~/.mozilla/firefox/<profile_folder>' it's the same, not rendering the entire window. I dont know why my profile is causing this problem, i only use three addons: AdBlock, BetterTTV and FoxyProxy, i have the same problem even if i dont have these installed.
Attached screenshots

All Replies (6)

more options

What happens under a different computer account?


Operating System: openSUSE Tumbleweed 20220515 KDE Plasma Version: 5.24.5 KDE Frameworks Version: 5.93.0 Qt Version: 5.15.2 Kernel Version: 5.17.5-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600

Modified by jonzn4SUSE

Helpful?

more options

I would try a live usb stick or VM of openSUSE Tumbleweed or any other OS to see if you have the same issue.

https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso

Modified by jonzn4SUSE

Helpful?

more options

You don't have to rename the .mozilla folder. Creating a new profile would suffice. What configuration are you doing to the profile?

Helpful?

more options

Did you try to start Firefox in Troubleshoot Mode and possibly disable hardware acceleration ?

You can try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

jonzn4SUSE said

I would try a live usb stick or VM of openSUSE Tumbleweed or any other OS to see if you have the same issue. https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso

Hello, before i post the problem i installed (third time) the same version of Kubuntu, worked fine but after i restarted my computer the problem came again. I tried using the same profile in elmentaryOS and it works perfectly and shows me:

"elementary@elementary:~/Downloads$ firefox --profile <path_profile>" ATTENTION: default value of option mesa_glthread overridden by enviroment.

I only installed some basic tools like: nmap, wireshark net-tools, golang-go, hugo, spotify, vscode, sublime-text. Maybe i should move to another OS.

Helpful?

more options

cor-el said

Did you try to start Firefox in Troubleshoot Mode and possibly disable hardware acceleration ? You can try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

I tried removing the xulstore.json with no luck, the same with the extensions/ folder, and as you can see in the screenshot, i can't see any button.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.