ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Log in problems on 3rd party websites

more options

On certain websites I notices I have 'unknown errors' when trying to log in.

Usually this is remedied by either using Chrome or clearing cookies and the cache.

Both of there are inconvenient and result in a great deal of wasted time.

The usual response by these websites is "get Mozilla to fix this".

I'm getting sick of this.

I don't want to switch to Chrome but I will have to if this persists.

On certain websites I notices I have 'unknown errors' when trying to log in. Usually this is remedied by either using Chrome or clearing cookies and the cache. Both of there are inconvenient and result in a great deal of wasted time. The usual response by these websites is "get Mozilla to fix this". I'm getting sick of this. I don't want to switch to Chrome but I will have to if this persists.
Attached screenshots

الحل المُختار

dominicpukallus said

Why doesn't Chrome have this problem?

Chrome is more used by internet users; hence many site-makers ignore the compatibility with other platforms.

If you are blocking things, chrome doesn't do that at all by default (except for 3p cookies).

What Cor-el said is probably what you need, as that page works for me on Firefox 99.0 (Canonical build) with uBlock Origin on nightmare mode with exceptions for javascript and *.afterpay.com

Read this answer in context 👍 1

All Replies (7)

more options

It seems that Enhanced Tracking Protection is blocking things on that website, potentially causing breakage. Please read the following for more information and how to disable it on a per-site basis.

Enhanced Tracking Protection is a collection of Firefox features that protects your privacy by blocking trackers that follow you online to collect information about your browsing habits and interests. It also includes protection against harmful scripts.

If a site seems broken, you can try turning off Enhanced Tracking Protection for that website only:

  1. Click on the shield Fx89ShieldIcon to the left of the address bar.
  2. Toggle the switch Fx91ETPbluetoggle at the top of the panel.
    Fx91SiteFixedSendReport

This will allow trackers to load on that website while keeping you protected on other sites. To learn more, see Enhanced Tracking Protection in Firefox for desktop.

Helpful?

more options

So to get FF to work with this website I have to turn off protective features on this website?

What good are the protective features then?

Not much of a solution.

I might have to go with Chrome.

Why doesn't Chrome have this problem?

Helpful?

more options

I just tried it anyway and the problem persists.

Chrome is looking better all the time.

Helpful?

more options

To repeat: Why do I get these problems with FF and not with Chrome?

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click the shield icon for more detail and possibly disable the protection. You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Modified by cor-el

Helpful?

more options

الحل المُختار

dominicpukallus said

Why doesn't Chrome have this problem?

Chrome is more used by internet users; hence many site-makers ignore the compatibility with other platforms.

If you are blocking things, chrome doesn't do that at all by default (except for 3p cookies).

What Cor-el said is probably what you need, as that page works for me on Firefox 99.0 (Canonical build) with uBlock Origin on nightmare mode with exceptions for javascript and *.afterpay.com

Helpful?

more options

Thanks I'd ignored the overlapping tracking blockers I had as add-ons. I disabled the DuckDuckGo tracking blocker which I had as well as uBlock (overkill) and the problem went away. I'll remember this next time (if ever).

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.