ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox stopped displaying a CSS mask locally

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 63 views
  • آخر ردّ كتبه Sergey Martinov

more options

I use Firefox locally to review the HTML/CSS while creating web pages (Win7 & Win10). Upon browser update, Firefox stopped displaying mask of any image format (SVG or PNG).

I did solve this issue in 2020 by changing the settings. about:config > privacy.file_unique_origin changing: to 'false' > refresh tab. Yet, since October 2021, it's no longer helping. After a browser update, I don't see the images with a mask, see attachment. The mask images show OK when the HTML page is on the server, but codding requires a constant 'quick check,' and usually uploading to the server is a final step. Can anyone help?

I prepared a simple example page [https://artenergy.com/mask] with a download link. Thus one can open this file locally to see the issue.

Thank you!

I use Firefox locally to review the HTML/CSS while creating web pages (Win7 & Win10). Upon browser update, Firefox stopped displaying mask of any image format (SVG or PNG). I did solve this issue in 2020 by changing the settings. about:config > privacy.file_unique_origin changing: to 'false' > refresh tab. Yet, since October 2021, it's no longer helping. After a browser update, I don't see the images with a mask, see attachment. The mask images show OK when the HTML page is on the server, but codding requires a constant 'quick check,' and usually uploading to the server is a final step. Can anyone help? I prepared a simple example page [[https://artenergy.com/mask]] with a download link. Thus one can open this file locally to see the issue. Thank you!
Attached screenshots

Modified by Sergey Martinov

الحل المُختار

This pref is still supported, but will be removed as well in the future.

  • security.fileuri.strict_origin_policy = false

Safest is to use a separate profile with this feature disabled for testing locally.


  • 1730535 - Remove the security.fileuri.strict_origin_policy pref, always require unique origins

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 👍 1

All Replies (2)

more options

الحل المُختار

This pref is still supported, but will be removed as well in the future.

  • security.fileuri.strict_origin_policy = false

Safest is to use a separate profile with this feature disabled for testing locally.


  • 1730535 - Remove the security.fileuri.strict_origin_policy pref, always require unique origins

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

more options

Thank you much, this did the trick, and now I can see the 'mask image' again. Your help is appreciated a lot!

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.