ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Interface language changes to languages I cannot read

  • 7 ردود
  • 3 have this problem
  • 192 views
  • آخر ردّ كتبه FredMcD

more options

The browser's interface language, including links, menus, ads etc., changes without warning into languages I don't know. Sometimes the whole screen is in one language, at other times, several languages are on the same page. Even after re-selecting the preferred language, the problem persists.

The browser's interface language, including links, menus, ads etc., changes without warning into languages I don't know. Sometimes the whole screen is in one language, at other times, several languages are on the same page. Even after re-selecting the preferred language, the problem persists.
Attached screenshots

All Replies (7)

more options

Do you have language pack installed, see "Add-ons -> Languages" ?

The language setting in Settings is about the language for the user interface and the preferred language for webpages.

If the Firefox user interface (toolbars) is in the wrong language or if you want to change the current language then download Firefox in the language of your choice.

You can try to clear the startup cache via the "Help -> More Troubleshooting Information" (about:support) page.

more options

I have this problem as well, and it's driving me nuts. My language settings are correct, and I've flushed my cache and history too. I have also tested in other browsers and it is fine, so it is specific to Firefox.

more options

Try reinstalling Firefox in the language of your choise; Download Firefox For All languages And Systems {web link}

more options

Note that you appear to have a user agent that is modified by Avast Anti-Track that could be causing problems, so if you do use this software then try to disable it. You will have to contact Avast about this if their software causes problems for you. We can't do much about this apart from identifying Avast Anti-Track as a possible cause.

more options

I have this problem, also.

Certain sites, particularly eBay, Amazon, and now GMail, open in languages other than English. I have cleared caches, history, etc., and have them set to clear automatically when Firefox is closed. I also have all language options set to English (US). This is quite annoying, and I don't know why it started in the first place.

I've turned off all my add-ons, to no avail. I don't use Firefox's VPN, but do use Bitdefender's VPN. However, this problem occurred before I installed Bitdefender.

WHY can't this be fixed? PERMANENTLY!

more options

The same thing is happening to me as tanbrae1 reported. Some sites are loading in Spanish rather than English and only in Firefox. Its frustrating. My language settings are set properly, I've cleared cache, cookie, etc several times. I've tried troubleshooting mode. The language on sites like Yahoo and PayPal continued to be wrong in troubleshooting mode. This has been happening for a while and I try to troubleshoot as I have time. In the past I've even fully uninstalled Firefox and removed all data and then reinstalled. It begins to occur again after some time.

more options

Some websites will send their data depending on where the website thinks you are.

Are you using a VPN?


What do these websites say about your location?

http://whatismyipaddress.com/ Under the map, look for Location Not Accurate?

http://browserleaks.com/geo

https://whatismyipaddress.com/geolocation

https://html5demos.com/geo/

https://www.iplocation.net/find-ip-address

How to set your location manually in Firefox(Windows) https://support.mozilla.org/en-US/questions/1197142#answer-1115502

https://support.mozilla.org/en-US/kb/does-firefox-share-my-location-websites