ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Now have to mouse click the cursor in the search box before I can type

  • 20 ردًا
  • 1 has this problem
  • 122 views
  • آخر ردّ كتبه roundball

more options

Strange little problem has started recently and am thinking it might be related to the latest couple of FireFox updates. When I open FireFox and try to start typing in the search engine box, nothing happens...I have to click the mouse pointer on the cursor to seem to activate it for lack of a better term...and then I can start typing OK. [ No other typing / mouse click related problems with anything else what-so-ever ]

The cursor automatically goes right into the search box like it should, sitting there blinking for me to simply start typing from the keyboard. But typing is unresponsive, no typing occurs until I now take the extra step and mouse click on the cursor., then I can type OK.

Default browser is FireFox...the behavior is the same on multiple search engines of Google, DuckDuckGo, and Wikipedia. Since Firefox was a common denominator, I uninstalled FireFox, reinstalled it…but no help. Yet, if I try Internet Explorer from the ‘Windows Accessories’ section, it's search box typing works normally. Any experience / known issues would be appreciated.

الحل المُختار

Well lo and behold...

I installed the latest Microsoft cumulative update that just arrived, and it fixed this problem !!

Read this answer in context 👍 0

All Replies (20)

more options

Try starting Firefox in safe mode and then check if the issue persists


If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Modified by Daniel Ebenezer

more options

Tried that, but no help. However, in further troubleshooting, the failures definitely seem FireFox related as follows:

A-There are no other immediate typing problems with anything else...only when FireFox related;

B-When I download Google and DuckDuckGo shortcuts from the Internet, then launch either of them directly from my desktop ( standalone, not as FireFox add-ons ) typing works immediately in each of their search boxes as it should. [ That's why Internet Explorer also worked normally as I had launched it standalone ]

But none of them allow normal immediate typing as FireFox Add-ons; And there are no outstanding updates for them as FireFox add-ons; So at the moment, FireFox appears to be the common denominator.

Modified by roundball

more options

Do you mean the address bar or a search box in your home page?

Can you tell whether Firefox is still the focused application? This can be difficult to tell because the changes in the top row are very subtle (slightly faded text on tabs when another window has the focus).

more options

When search engines like Googe, DuckDuckGo, etc, are set up as the home-page in a browser like FireFox, they open up on the whole screen, and have a search box horizontally right across the middle of the screen, with the cursor waiting / blinking in it for typing to begin...exactly the same as when you launch one of those search engines standalone.

Modified by roundball

more options

12/22/20-pm UPDATE

Another discovery…using various search engines in FireFox where I have to mouse click the search box to seemingly get the page to come alive and allow typing…is that I can go to the upper left corner of the screen and click the “Reload The Page” symbol…and that then allows typing to take place in the search box.

( click to enlarge attached screenshot )

Modified by roundball

more options

Does the problem occur at any time other than the initial startup? For example, when opening a new window (Ctrl+n or using the Taskbar icon > right-click > Open new window).

more options

If I'm understanding the point of your question correctly, so far, it only seems to happen when a search engine has been set as the home page for FireFox...which I've always done for years and years.

I click my FireFox shortcut on my desktop which opens to the assigned search engine screen...looks normal but its functionality is dormant...won't allow typing in the search box where the cursor is sitting / blinking.

But if I specifically click on the blinking cursor in the search box...(not even click just anywhere in the empty search box but have to specifically click on the blinking cursor)...or click the 'reload this page' icon, top left of screen...the page then becomes responsive, I can type and use it fine for as long as I'm using it.

But I can close it, open it right back up, and the screen once again just sits there, unresponsive.

Yet as I previously mentioned, if I download shortcuts to the same search engines like Google, DuckDuckGo, Internet Explorer, etc...and use them standalone from their direct shortcuts on my desktop they all work perfectly normal first time, every time.

Modified by roundball

more options

I'm trying to distinguish between a problem that occurs only at startup versus problems with opening the identical page in another window. So at startup, it doesn't work for some reason until you click in the page or on the reload button. How about if, after you have started up, you launch a new window by pressing Ctrl+n. Firefox should load the identical home page, but without any of the startup distractions. Can you type into the page immediately in the new window?

more options

Ah, got it...

Yes...once I get the initial search engine screen "activated".....I can then click open additional instances of that same search engine associated with FireFox and the additional instances are also activated / work as they should.

more options

Okay, so one possibility is that the Firefox window is losing focus at startup. You could try other keyboard actions such as

  • Ctrl+f to open the Find bar
  • F6 to move the cursor to the address bar

If nothing happens, then Firefox, even if it appears in front of other windows, may not actually be focused for some reason.

If you hold down the Alt key and press and release the Tab key, Windows should show the Task switcher overlay. Usually the window that had the focus before you triggered the Task switcher will appear immediately to the left of the selected window. Is that Firefox, or some other window?

more options

Fresh boot up

Click FireFox icon pinned to my task bar

DudkDuckGo search engine screen opens (because I set it as home screen for FireFox) (Same if I set Google, or any other search engine as home screen for FireFox)

Alt-Tab screenshot below:

more options

Oh, I see, you started Firefox when there are no other windows open yet, so the Task switcher doesn't show any other tasks.

And the other focus tests also failed immediately after bootup before you click on the window?

more options

Those other 2 little things didn't do anything related to this problem...either from my desktop screen or from the search engine screen. Well, the F6 does do something...by design, it increases brightness of the screen, LOL

Getting late on Christmas eve...thanks for trying to help...this might even turn out to be some sort of Win 10 update issue or something.

more options

Does pressing the Tab key once set focus to the input field ?

more options

Does pressing the Tab key once set focus to the input field ? .......................................................................................................

If you would, please put a few more words around that so I'll know exactly which key you're referring to in the following set of circumstances: A) I power up to the desktop screen; B) Then click my FireFox icon on the task bar; [ FireFox is set with a search engine as its home screen...ie: Google, DuckDuckGo, etc...all fail the same way ]

C) Search engine screen pops up normally, cursor is blinking in the search box as it should be; D) When I try to type, nothing types...cursor just sits there blinking; E) If I click on the cursor...or click "reload the page"...the screen then comes to life and accepts typing.

Modified by roundball

more options

Hope everybody stayed healthy over Christmas...here's a new information update: .....................................................................

Searching the web for FireFox having no focus in search boxes of home page search engines, I found a few hits over the years...seemed to come in waves, appear, then dry up then reappear, etc…as though for example it was a FireFox bug that then got fixed and things settled back down for a while…just guessing…but none that I found listed a meaningful fix.

However, I did run across a very interesting post that I can recreate exactly...it's sort of a temporary circumvention and the problem still needs to be fixed of course…but it might be very revealing to the FireFox community brain trust.

If I DOUBLE CLICK my FireFox icon on my desktop task bar like I’ve done untold thousands of times over the years…whatever search engine I happen to be trying as a home page for Firefox opens with the cursor blinking in the search box as normal...BUT is not responsive to typing.

HOWEVER:

If I only SINGLE CLICK the FireFox icon on my desktop task bar…the FireFox home page search engine opens and looks normal the same way…BUT…typing is allowed to start immediately as it normally should. [ For the heck of it, I even experimented with rapid #'s of clicks on the desktop task bar icon...1, 3, 5 odd #’s of clicks always worked, even #’s of 2 or 4 clicks always failed ]

Tried it several times back & forth and it works like that every time. Something has changed somewhere…happens with multiple search engines so they’re not the problem…has to be some sort of common denominator.

Modified by roundball

more options

It's possible that double-clicking the Taskbar icon interrupts the launch sequence that usually makes Firefox the focused window.

more options

.....If I DOUBLE CLICK my FireFox icon on my desktop task bar like I’ve done untold thousands of times over the years…


.....Something has changed somewhere…happens with multiple search engines so they’re not the problem…has to be some sort of common denominator...

more options

02/06/21 - Just checking in to see if anyone might have responded with a fix...

Modified by roundball

more options

الحل المُختار

Well lo and behold...

I installed the latest Microsoft cumulative update that just arrived, and it fixed this problem !!