ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Profile Manager doesn't appear when a profile is already open

  • 9 ردود
  • 1 has this problem
  • 20 views
  • آخر ردّ كتبه MartyJames

more options

I use multiple Firefox profiles. Normally, Profile Manager always appears at launch.

But lately, if I launch Firefox while a profile is already open, it just opens a new window in the current profile. The only way I can get Profile Manager is by typing firefox.exe --profilemanager.

For the record, I don't have this option enabled: Use the selected profile without asking at startup.

Modified by MartyJames

الحل المُختار

MartyJames said

Hmmm… OK, so I presume Mozilla doesn't expect us to launch multiple profiles at once?

Why would you presume that? If you haven't already, try adding -ProfileManager or -P to the command line of your shortcut:

Right-click the shortcut, click Properties, and Windows usually focuses the Target field of the Shortcut tab.

Normally it would have something like this:

"C:\Program Files\Mozilla Firefox\firefox.exe"

You can add a space and then -P on the end so that the shortcut always calls up the profile manager dialog.

Read this answer in context 👍 0

All Replies (9)

more options

Anyone?

Helpful?

more options

If Firefox is already open, a profile is already active.

Helpful?

more options

I think this is normal since Firefox 67, which updated how different builds of Firefox start up in different profiles.

Helpful?

more options

Hmmm… OK, so I presume Mozilla doesn't expect us to launch multiple profiles at once?

Helpful?

more options

Open Firefox. Then the Profile Manager. One profile will be listed as 'in use.'

The others should have a button to start it in a different browser.

Helpful?

more options

الحل المُختار

MartyJames said

Hmmm… OK, so I presume Mozilla doesn't expect us to launch multiple profiles at once?

Why would you presume that? If you haven't already, try adding -ProfileManager or -P to the command line of your shortcut:

Right-click the shortcut, click Properties, and Windows usually focuses the Target field of the Shortcut tab.

Normally it would have something like this:

"C:\Program Files\Mozilla Firefox\firefox.exe"

You can add a space and then -P on the end so that the shortcut always calls up the profile manager dialog.

Helpful?

more options

jscher2000 said

Right-click the shortcut, click Properties, and Windows usually focuses the Target field of the Shortcut tab. Normally it would have something like this: "C:\Program Files\Mozilla Firefox\firefox.exe" You can add a space and then -P on the end so that the shortcut always calls up the profile manager dialog.

Thank you sir, but when I try this, I get the error:

" Problem with Shortcut

The name 'C:\Program Files (x86)\Mozilla Firefox\firefox.exe -p' specified in the targer box is not valid. Make sure the path and file name are correct. "

Helpful?

more options

This is what I use: Note the quotes "C:\Program Files (x86)\Mozilla Firefox_Curr\firefox.exe" -p Current

Helpful?

more options

FredMcD said

This is what I use: Note the quotes "C:\Program Files (x86)\Mozilla Firefox_Curr\firefox.exe" -p Current

Ah, thank you. I had the quote in the wrong place! :-)

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.