Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

notifications stopped working

  • 11 replies
  • 2 have this problem
  • 102 views
  • آخر ردّ كتبه AliceWyman

more options

Context: after upgrading FF I started using the new version the day after. I always set FF to open with the tabs I was using before exiting. When I opened FF I got a bunch of youtube offline notifications as usual. I didn't get twitter offline notifications but this happens from time to time. Eventually notifications from yt stopped but I only noticed it many hours later when I tried to Push notifications on twitter https://twitter.com/settings/push_notifications I got this as a result: Unsupported browser It looks like your browser doesn’t support push notifications. Important most likely: when I was working during the afternoon FF started lagging I got impatient so I ended the heaviest FF process with Windows Task Manager. I could continue working normally. Trying to find a fix on google I ended up here: about:debugging#/runtime/this-firefox#serviceworkers

The YT service worker always shows:

  • Stopped - Not listening for fetch events

But the twitter service worker shows Stopped (if twitter isn't open yet) and 'running' if it is open. However it always shows no matter if it's running or not: Listening for fetch events

In Debugging - runtime Youtube Service worker I clicked: 'Start' (it showed running instead of stopped)+ 'Push'

Tons of offline yt notifications popped up at the right corner of the screen as usual, I did notice though that they were offline, they weren't happening at that moment. After like a minute again showed the same: * Stopped - Not listening for fetch events

For twitter Service Worker it showed it was running so I clicked 'Push' instead of tons of offline notifications from people I follow and followers I got only one notification pop at the bottom from twitter itself saying: New notification, I clicked it and it took me to twitter notifications where all of them are. I tried pushing notifications on here: https://twitter.com/settings/push_notifications but again: Unsupported browser - It looks like your browser doesn’t support push notifications. The Service Worker keeps saying: Listening for fetch events

Is there anything I can do to make it work all the time as it used to? What about doing a FF restore to some days ago? In the past doing that sorta restore helped but with a very different issue. However could it work? Any other fixes that I should try?

The image attached shows a Service Worker for spotify but I never allowed a notification from it, that I can remember? If I did, I never got any.

Attached screenshots

All Replies (11)

more options

Are you possibly using "Delete cookies and site data when Firefox is closed" ?

If this is the case then you may have to create a cookie allow exception with the proper protocol for these websites (domains) to make service workers work.

Helpful?

more options

cor-el said

Are you possibly using "Delete cookies and site data when Firefox is closed" ? If this is the case then you may have to create a cookie allow exception with the proper protocol for these websites (domains) to make service workers work.

Hi, thanks for the reply! No I don't, I never touch cookies anywhere just in case. I'm not sure if it's good or bad idea, but I always allow cookies anywhere and never delete them.

Helpful?

more options

New development. I'm working right now, I was listening to music playing yt videos and I saw a yt notification pop up outta the blue! I checked the notification bell on yt and it was a 'live' notification, dunno how to say it in English, like it was notifying me of a video that was uploaded right then! Now I'm having regular notifications. I immediately went to check here: about:debugging#/runtime/this-firefox#serviceworkers And here's what it says for the YT service worker:

  • Stopped
Push Service - 
   https://updates.push.services.mozilla.com/wpush/v2/gAAAAABfTRkBMiSzo56SESTb4KgFXlG0BOQDyUVzQ60-scUgi5owXvaz9q7Gwnl5rwz0hXeTOyJESNWVDWSY2br4vJchNdSixs-ExX0FL-ErKfracZgwLE0LhmyLhUj7xUP-fwy_mLAX1T7DoCgh2ed6r0b4a-X1basoV0DRujY46vmMcaXKFLk

Fetch -

   Not listening for fetch events

So it showed that new thing that was never there: Push Service -

   https://updates.push.services.mozilla.com/wpush/v2/gAAAAABfTRkBMiSzo56SESTb4KgFXlG0BOQDyUVzQ60-scUgi5owXvaz9q7Gwnl5rwz0hXeTOyJESNWVDWSY2br4vJchNdSixs-ExX0FL-ErKfracZgwLE0LhmyLhUj7xUP-fwy_mLAX1T7DoCgh2ed6r0b4a-X1basoV0DRujY46vmMcaXKFLk

Now I check again and it says 'running' instead of 'stopped'. In the image attached it shows the ss I took the second I loaded the debugging - runtime. Of course I immediately tried twitter and I could push notifications! No longer saying unsupported browser. I shouldn't have them on, I'm working right now, I don't really want notifications but I'm afraid it's going top 'break' again. Also I see the service worker for IG lol I forgot I had those notifications on too! But I don't use IG regularly on the laptop, that's why. I did use it today after clicking a link for a story!!!! Any ideas what could this be? It's so random but I doubt it is. Besides I'd love to be able to change the notifications status but now I'm scared to touch anything.

On the 2nd image it shows the same thing for twitter service worker:

Push Service -

   https://updates.push.services.mozilla.com/wpush/v2/gAAAAABfTRuMNNfBt7Tc_Z4zY-tNyDj7o6RUZMSepoaaSOAv1tnPC7vgqNCz7NNpOSvNDHaBdHzFE9OHJSAUzF-oGOVHh6I4qROhvIkdU_BFa3M2C1d-0BQuRMD6lRYfRNovmDP79gYluC2HzKlvu9FoZCpowNkO_8Zk5O-SBbwtPSyCIiQy8Hs

Fetch -

   Listening for fetch events

Any ideas or suggestions? What could have happened and how do I prevent it from happening again? Please let me know if I should click this problem as solved! I hope it is, but since I'm clueless as to why any of this happened, I'm not sure it is?

Helpful?

more options

cor-el said

Are you possibly using "Delete cookies and site data when Firefox is closed" ? If this is the case then you may have to create a cookie allow exception with the proper protocol for these websites (domains) to make service workers work.

So yesterday was a fluke since today I not only didn't get offline notifications, which I wouldn't have a problem with if the notifications started working when I started using the platform? I didn't try twitter but I'm again listening to music watching videos on yt and I'm not getting notifications. I didn't open twitter (afraid of getting flooded by notifications again since I'm working) that's why its service worker isn't showing in the debugging-runtime SS. Here's what it shows for YT service worker:

Stopped

Push Service -

   https://updates.push.services.mozilla.com/wpush/v2/gAAAAABfTRkBMiSzo56SESTb4KgFXlG0BOQDyUVzQ60-scUgi5owXvaz9q7Gwnl5rwz0hXeTOyJESNWVDWSY2br4vJchNdSixs-ExX0FL-ErKfracZgwLE0LhmyLhUj7xUP-fwy_mLAX1T7DoCgh2ed6r0b4a-X1basoV0DRujY46vmMcaXKFLk

Fetch -

   Not listening for fetch events 

It's the same as yesterday. I'm scared to click on 'start' since yesterday it started working out of the blue and I wouldn't wanna prevent it from happening again by forcing something? I might try it later if I'm not as lucky as yesterday

Helpful?

more options

Hi, I also have the same problem, push notifications don't work. I installed firefox 80.0.1 on openSUSE Leap 15.2, I also opened a discussion on the Italian forum but no one answered me. https://forum.mozillaitalia.org/index.php?topic=74824.0 The intr0uble and mine screens are identical. I think it's a bug

Helpful?

more options

You can check the Web Console for possible related messages.

You can see all registered service workers on these pages:

  • about:serviceworkers
  • about:debugging#workers

You can check WebSockets via this page:

  • about:networking#websockets

See also serviceworker.txt in the profile folder.

Helpful?

more options

I think there is a problem

Helpful?

more options

I have the same problem. They stopped working for twitter. I try to activate them again and it says the browser is unsupported. Also tried here: https://gauntface.github.io/simple-push-demo/ It says "Ooops a Problem Occurred AbortError: Error retrieving push subscription." I have tried deleting cookies for those pages and restarting firefox with no extensions, nothing helped. However, if i create a new profile or use a portable version of FF, they work fine.. it seems it's only affecting that specific profile. But why? By the way, some websites seem to be working fine, i still receive whatsapp notifications.

Helpful?

more options

Was my comment deleted? Did i do something against the rules?

Helpful?

more options

Anyway, i was having the exact same problem on twitter and on the test website i posted in my deleted comment. I just tried again and it's working fine for both so whatever it was, got fixed.

Helpful?

more options

Mike said

I have the same problem. They stopped working for twitter. I try to activate them again and it says the browser is unsupported. Also tried here: https://gauntface.github.io/simple-push-demo/ It says "Ooops a Problem Occurred AbortError: Error retrieving push subscription." I have tried deleting cookies for those pages and restarting firefox with no extensions, nothing helped. However, if i create a new profile or use a portable version of FF, they work fine.. it seems it's only affecting that specific profile. But why? By the way, some websites seem to be working fine, i still receive whatsapp notifications.

This reply was in the moderation queue. I released it.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.