Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox freezes computer when using hardware accelleration

  • 2 replies
  • 1 has this problem
  • 10 views
  • آخر ردّ كتبه Mike

more options

There is an older thread that describes the same symptoms, but seems limited to nVidia GPU's. I have a:

  • Dell Latitude E7470 that has an Intel HD 520 GPU (Dell driver v26.20.100.6888, Feb 24, 2019). Win10 x64, running 32bit FF v77.
  • Dell OptiPlex EX3, with an Nvidia Quadro P2200 GPU (driver v442.92, Apr 16, 2020). Win10 x64 running 64bit FF v77.

Both exhibit this problem, but the EX3 is a more recent development. If I disable hardware acceleration, no crashes. With acceleration, the computer freezes. There is no crash, it just simply locks solid forcing an unclean shutdown. Plugins active or uninstalled, doesn't matter. Nothing in the Event Viewer but an unexpected shutdown. I've just installed the Intel driver ( v27.20.100.8280, May 29, 2020) onto my laptop to see if there is any improvement, but it's a wait and see thing.

All Replies (2)

more options

Hello mike,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.
  • In Firefox 55 and above:

Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux). Select the General panel. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed. Fx55Performance-disableHWA Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems Upgrade your graphics drivers to use hardware acceleration and WebGL

Thank you.

Helpful?

more options

Possibly you didn’t completely read my post. I indicated that I had done this, and that no crashes occur this way. However this not a solution. It’s a bandaid. Performance in Firefox is noticeably lessened on sites that benefit from the feature by disabling this. Per the archived post I linked to, this has been a problem for nearly two years.

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.