Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

There is no button labeled "Turn off Blocking for This Site."

  • 31 replies
  • 3 have this problem
  • آخر ردّ كتبه slatersteven8

more options

I am trying to get content from . They need me to disable tracker blocking. The standard help screen (capped below) says to just click the button labeled "Turn off Blocking for This Site." Only trouble is, no such button actually exists on the information popup screen (Clicking the circled 'i'). The popup screen I get looks exactly like the one in the help, except for the missing button. I have tried all the suggestions in other posts and none of them work. I notice I am not the only one with this problem. Is it possible my install of Firefox is corrupted? But nothing else I have noticed is wrong. I am running Firefox quantum 68.0.1 under Ubuntu xcfe.

Attached screenshots

All Replies (20)

more options

Are you using any ad-blocking add-ons/programs? Click on its icon.

more options

Yes, I am using Ad-Blocker but I have the site white-listed. Plus, I also tried restarting with add-ons disabled, and the same thing - no button.

more options

Make sure you are not blocking content.

One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature:

more options

It is simply not true that the shield icon always appears; sometimes (like on it is the circled i icon.

Everything the help screen says I ought to see, I see, except for the "Turn off Blocking for This Site" button. If this is, as you say, a more common issue lately, maybe there is actually something wrong with Firefox? Ever think of that? Ever look into it?

I tried switching to the standard Ubuntu Studio desktop, thinking the problem was with Xcfe, but no, same thing. No button.

more options

Hello josephfg105,

Would you please make sure that you're not in permanent Private Browsing mode :

3-bar menu (or "Tools") => Options/Preferences => Privacy & Security => under 'History' => Firefox will : choose : "Use custom settings for history" Uncheck : "Always use private browsing mode"

more options

^ A web page may try to use features that aren't available in Private Browsing mode and then assume that you use PB mode if it can't use a specific feture.

If there isn't any blockable content then you won't see this button. What only matters is if there is blockable content detected on the page.

Can you post a screenshot of the drop down panel that you get on that website?

You can check the Web Console for possible error messages about blocked content.

  • "3-bar" menu button or Tools -> Web Developer
more options

@McCoy, the check box was already unchecked. I normally keep it on "Remember History."

@cor-el, unfortunately I cannot get a screen shot to include the drop-down menu. The menu goes away when I hit the PrtSc key. However I can tell you that the drop-down says, "blockable content detected on this site." Specifically, the section underneath "Connection" has a shield icon and says "Content Blocking," and then "Custom" and then a gear icon; next line has "Blockable content detected on this site" in gray; next line has a cookie icon and then "Cookies" and then an arrow, and that's it for that section.

Going to and bringing up Web Console, I get the following messages, which I exported to clipboard:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at…7903a6a4a4:T=1564887606:S=ALNI_MYqwXxFIQ6I3KEwZeIbPLbgL1hjAw. (Reason: CORS request did not succeed). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS request did not succeed). --Zeus DEBUG-- : AFC Off. wp-ad.min.js:6:10971 Loading failed for the <script> with source “”. Loading failed for the <script> with source “”. Loading failed for the <script> with source “”. Loading failed for the <script> with source “”. Loading failed for the <script> with source “”. Loading failed for the <script> with source “”. Loading failed for the <script> with source “”. Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS request did not succeed). [shouldPlayAd] false, disabled in data powaBoot.js:8:5765 Initialize USW f4c6b57aee.js:1:29 TWP.Identity 6b62210598.js:9:22 [3.732] STARTING Paywall 6b62210598.js:36:455 PAYWALL CHECK STATUS: 6b62210598.js:37:59 PWAPI URL: 6b62210598.js:37:133 PAYWALL ACTION: 0 6b62210598.js:37:374 PAYWALL URL: (null) 6b62210598.js:37:454 PAYWALL SUB: Unsubscribed 6b62210598.js:38:22 PAYWALL METERED: Unmetered: content_type 6b62210598.js:38:123 PAYWALL METER COUNT: 0 6b62210598.js:38:228 PAYWALL MODE: 1 6b62210598.js:38:317 Could not find a player div on the page, skipping WapoVideoEmbed.min.js:1:5818 Invalid URI. Load of media resource failed. Loading failed for the <script> with source “”.

more options

You haven't mentioned what your Content Blocking settings are - if, for instance, you have chosen "Custom" and unchecked every option, you will not get the "Turn off Blocking for This Site" button.

Here I have Content Blocking set to "Standard" - that's when the button appears, see screenshot.

Modified by McCoy

more options

Custom, chosen to block trackers in all windows. When I click "change block list" I can only choose level one or level two. I have level one (allow some trackers so fewer web sites break). But the panel in question said "blockable content detected on this site," so, there is blocking being done here. I should see the button to disable, but I don't.

more options

'Just set my content blocking the way you have, and the "Turn off Blocking for This Site" button is there - see screenshot.

I really don't know why this doesn't work for you - maybe someone else does.

more options

FWIW : No matter my content blocking settings on Washington Post - the site only asked me to turn of my adblocker (in my case ABP), which I did.

The site is a bit quirky, fickle, though : I can visit the site ten times without any problems, then all of a sudden they'll (again) ask me to turn off my adblocker (which of course is turned off) .....

more options

josephfg105 said

It is simply not true that the shield icon always appears; sometimes (like on it is the circled i icon.

I just went over this thread again and only just now noticed the above mentioned sentence .....

If you don't see a shield icon next to the padlock, that means that Firefox isn't blocking content, in which case you won't see the "Turn off Blocking for This Site" button.

The 'i' in a circle you will see on every site, as it leads to the site's Control Center.

(Why, on the Washington Post, Firefox blocks content for me and not for you : I don't know)

Modified by McCoy

more options

If this is about ads on the page then you usually get ads offered that are targeted to your location. You will only see the shield if you get ads that are in the current block list.

more options

Here is my screenshot from today visiting . Please note the following: 1. AdblockerPlus is switched off for this site (octagon icon between the green circle and the red square, upper right, is gray.) 2. Firefox is not blocking content (no shield icon, only an i in a circle.) 3. still claims I am blocking ads, and offers me a paid subscription (large blue rectangle on the left.)

You can see why I am frustrated, and why none of the solutions offered here help. Is the problem with If that is the case then I want to inform them of that, and it would be useful to reference this thread, I think, so that they can see it isn't with me or with Firefox.

Modified by josephfg105

more options

^ See my penultimate post .....

Might be a good idea to contact them :

more options

Hi josephfg105, what is the "fence" icon on your toolbar? Is that Facebook Container, or a different "container" add-on?

To see whether there might an add-on interaction that hasn't been accounted for, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

(To return to normal, quit out of Firefox and start it up normally.)

more options

@jscher2000, that is Facebook Container. If you see my first reply above, you will note that I did try safe mode. From what I've learned here, of course there was no button, but that isn't the point. The point would be to access the site I want while running the add-ons I want -- which is the purpose of the "Turn of blocking. . ." button. Anyway, I also happen to be all out of free articles with the Post by now, so now I get THAT pop-up box instead, even in safe mode.

@McCoy, thanks. I think it must be a problem with the Post's site somehow. I will try to straighten it out with them.

Thanks to everyone for your help!

more options

@josephfg105 Hi Joseph, give this a try. Open up about:preferences#privacy Then scroll down to "Cookies and Site Data" Now "Manage Permissions..." You'll be brought to "Exceptions - Cookies and Site Data" Now you can type in the web address, hit "Allow," and then "Save Changes."

I had the same problem, although with a different site, and this seemed to do the trick. If you'd like to exactly reproduce my steps, you'll also have a Bourbon Old Fashioned nearby. Even if the above doesn't work, at least it will take the edge off. And if it does work, you'll need to take the edge off anyway once you read the news.

btw Simple Syrup is just sugar and water. microwave a bit of sugar and an equal amt water for 30 - 40 secs, take it out and stir until the sugar dissolves. use as much or as little sugar as you like. secret - you can use cheap Bourbon; once you've added the other ingredients you probably won't be able to tell the difference.

Modified by Fels

more options

@Fels, Thanks, but, I already have as "Allowed."

more options

ah, ok. Sorry I couldn't have been more helpful.

  1. 1
  2. 2