X
Tap here to go to the mobile version of the site.

منتدى الدعم

Fix audio breaking issues with "text-to-speech" on google translate website

Posted

When playing audio with the "Listen" button at bottom-left of google translate website box, the "text-to-speech" audio sound is rough like it have latency issue or breaking sound or the sound is choppy as in the sound don't flow smoothly but when I download the audio file .mpeg from Web Developer -> Network then play it on Media Player Classic (CCCP) it have no issues but the problem is how to fix it so that FireFox can play it smoothly?

I already tried "Safe Mode" FireFox but it does not solve it, videos with sound like YouTube videos or DailyMotion videos or YouKu videos or NicoNicoDouga videos all have no issues with sound, all is smooth sound playing, only at the google translate website for the "text-to-speech" I experience any audio sound issues.

Please help!

When playing audio with the "Listen" button at bottom-left of google translate website box, the "text-to-speech" audio sound is rough like it have latency issue or breaking sound or the sound is choppy as in the sound don't flow smoothly but when I download the audio file .mpeg from Web Developer -> Network then play it on Media Player Classic (CCCP) it have no issues but the problem is how to fix it so that FireFox can play it smoothly? I already tried "Safe Mode" FireFox but it does not solve it, videos with sound like YouTube videos or DailyMotion videos or YouKu videos or NicoNicoDouga videos all have no issues with sound, all is smooth sound playing, only at the google translate website for the "text-to-speech" I experience any audio sound issues. Please help!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.75.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Shockwave Flash 23.0 r0
  • 5.1.30514.0
  • Unity Player 5.3.6f1
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

But google translate does not use adobe flash to be able to play its .mpeg audio files for "text-to-speech"? Even when I enable using flash on google translate website it is still the same issue so I do not think flash is an issue? In case you need to know my shockwave flash plugin version is 23.0 r0 and my gpu nvidia 8500 gt is aptly updated.

Also as I mentioned before I used FireFox in "safe-mode" before to attempt troubleshooting, if I remember correctly in "safe-mode" not even plugins will load? I get the same problem in both "safe-mode" and "normal" mode, both modes can play but both modes get the same problem and also tested with "activate" flash and "disable" flash still both can play the .mpeg and both still give choppy sound, I also did clear cache in case the error is in the file even though I know the file has no issue as stated in the file post if I download the .mpeg from "dev tools -> network" and play it using Media Player Classic (CCCP) or just recently tested foobar2k it plays smoothly and normally, I also tried "open in a new tab" when I select the .mpeg from "dev tools -> network" and play it in FireFox which give me the same result which is choppy audio, not smooth.

Also in the plugins in FireFox add-on settings, I have adobe flash/shockwave flash set to "ask to activate" and not "always activate". I also tested this on both "safe-mode" and "normal mode" with the same result which give the same problem.

Is it possible to force FireFox when encountering .mpeg format files to use adobe flash/shockwave flash to play? Because I do not know what FireFox uses to play .mpeg files, reason I ask this is maybe there is a possibility that whatever FireFox is using to play .mpeg files could be bug and I want to try using others to play .mpeg instead of I don't know what FireFox uses to play .mpeg because the choppy audio is really bad and it only affecting google translate "text-to-speech" function for me, other video/sound websites has no such issues.

But google translate does not use adobe flash to be able to play its .mpeg audio files for "text-to-speech"? Even when I enable using flash on google translate website it is still the same issue so I do not think flash is an issue? In case you need to know my shockwave flash plugin version is 23.0 r0 and my gpu nvidia 8500 gt is aptly updated. Also as I mentioned before I used FireFox in "safe-mode" before to attempt troubleshooting, if I remember correctly in "safe-mode" not even plugins will load? I get the same problem in both "safe-mode" and "normal" mode, both modes can play but both modes get the same problem and also tested with "activate" flash and "disable" flash still both can play the .mpeg and both still give choppy sound, I also did clear cache in case the error is in the file even though I know the file has no issue as stated in the file post if I download the .mpeg from "dev tools -> network" and play it using Media Player Classic (CCCP) or just recently tested foobar2k it plays smoothly and normally, I also tried "open in a new tab" when I select the .mpeg from "dev tools -> network" and play it in FireFox which give me the same result which is choppy audio, not smooth. Also in the plugins in FireFox add-on settings, I have adobe flash/shockwave flash set to "ask to activate" and not "always activate". I also tested this on both "safe-mode" and "normal mode" with the same result which give the same problem. Is it possible to force FireFox when encountering .mpeg format files to use adobe flash/shockwave flash to play? Because I do not know what FireFox uses to play .mpeg files, reason I ask this is maybe there is a possibility that whatever FireFox is using to play .mpeg files could be bug and I want to try using others to play .mpeg instead of I don't know what FireFox uses to play .mpeg because the choppy audio is really bad and it only affecting google translate "text-to-speech" function for me, other video/sound websites has no such issues.

Modified by LovelyJane

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Helpful Reply

Firefox Safe Mode disables extensions (add-ons) and themes. It does not disable plugins.

The links I provided tells you to check your flash player is up to date. It also tells you to check other things as well.

Firefox Safe Mode disables extensions (add-ons) and themes. It does not disable plugins. The links I provided tells you to check your flash player is up to date. It also tells you to check other things as well.

Modified by FredMcD

Question owner

I can't run the Intel Auto Update from the link you provided, it say I don't have Microsoft 4.5 framework or something, I only have up to 4.0 framework.

My system is windows xp pro 32 bit sp3.

I can't run the Intel Auto Update from the link you provided, it say I don't have Microsoft 4.5 framework or something, I only have up to 4.0 framework. My system is windows xp pro 32 bit sp3.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Use the Windows Updater to check your system for updates.

Use the Windows Updater to check your system for updates.

Question owner

I ran a check on the google translate website for the "text-to-speech" file that is obtained from "dev tools -> network -> mpeg -> save as filename: translate_tts.mp3" and decoded it, the details are:

format: MPEG-2 Audio 0 video stream, 1 audio stream, 0 subtitle stream

Audio Stream 0: Codec: MPEG-2 Audio Layer 3, MPEG-2A L3, bitrate 32 Kbps, bitrate mode CBR, sampling rate 22 KHz, 1 channel, resolution: 16 bits per sample

I read https://wiki.mozilla.org/Accessibility/Video_Codecs but it don't list mpeg or mp3 FireFox uses to read.

I just used Windows Media Player 9 to play the audio file I saved from using FireFox "dev tools -> network -> mpeg -> save as filename: translate_tts.mp3" and it plays smoothly.

What I don't get is why Windows Media Player 9 (WMP 9) and 3rd party software like Media Player Classic (CCCP) or foobar2000 (fb2k) can play google translate audio file when save as to my computer using FireFox's "dev tools -> network smoothly but software like FireFox cannot.

I don't really get the definition of choppy or whatever, but the closest definition I can describe based on the problem I am currently experiencing is like drinking a glass of water using a straw, however the straw has a tiny hole in it so when you are drinking the glass of water from the straw there will be tiny air bubbles or tiny gaps in it so you do not get a smooth flow, its like that when FireFox plays the "text-to-speech" function from google translate website, I mostly use Japanese translate to English then clicked the "Listen" button with the small "speaker" picture on the Japanese side to read the Japanese text loudly to me, I cannot read Japanese but I can understand from listening when google translate reads it to me in audio form.

Also the Windows Updater don't work, it send me to microsoft website saying support has ended http://go.microsoft.com/fwlink/?linkid=209191


Using Edit to add on post: About the glass of water with straw that has a tiny hole in it, the gap is very very small, but its there, I think it has more to do with quality of the sound, it also feels rough, one thing very noticeable is I use earphones to listen and it hurts my ears to listen to the FireFox rendering google translate "text-to-speech" audio, the sound is bad, but when listening to it on WMP 9, fb2k, CCCP, the sound is very pleasant and pleasing to the ears, it is not a matter of volume being too high or too low, it just feels rough and bad and I want FireFox to play it smooth too but I can't figure out why its like this for FireFox.

I ran a check on the google translate website for the "text-to-speech" file that is obtained from "dev tools -> network -> mpeg -> save as filename: translate_tts.mp3" and decoded it, the details are: format: MPEG-2 Audio 0 video stream, 1 audio stream, 0 subtitle stream Audio Stream 0: Codec: MPEG-2 Audio Layer 3, MPEG-2A L3, bitrate 32 Kbps, bitrate mode CBR, sampling rate 22 KHz, 1 channel, resolution: 16 bits per sample I read https://wiki.mozilla.org/Accessibility/Video_Codecs but it don't list mpeg or mp3 FireFox uses to read. I just used Windows Media Player 9 to play the audio file I saved from using FireFox "dev tools -> network -> mpeg -> save as filename: translate_tts.mp3" and it plays smoothly. What I don't get is why Windows Media Player 9 (WMP 9) and 3rd party software like Media Player Classic (CCCP) or foobar2000 (fb2k) can play google translate audio file when save as to my computer using FireFox's "dev tools -> network smoothly but software like FireFox cannot. I don't really get the definition of choppy or whatever, but the closest definition I can describe based on the problem I am currently experiencing is like drinking a glass of water using a straw, however the straw has a tiny hole in it so when you are drinking the glass of water from the straw there will be tiny air bubbles or tiny gaps in it so you do not get a smooth flow, its like that when FireFox plays the "text-to-speech" function from google translate website, I mostly use Japanese translate to English then clicked the "Listen" button with the small "speaker" picture on the Japanese side to read the Japanese text loudly to me, I cannot read Japanese but I can understand from listening when google translate reads it to me in audio form. Also the Windows Updater don't work, it send me to microsoft website saying support has ended http://go.microsoft.com/fwlink/?linkid=209191 Using Edit to add on post: About the glass of water with straw that has a tiny hole in it, the gap is very very small, but its there, I think it has more to do with quality of the sound, it also feels rough, one thing very noticeable is I use earphones to listen and it hurts my ears to listen to the FireFox rendering google translate "text-to-speech" audio, the sound is bad, but when listening to it on WMP 9, fb2k, CCCP, the sound is very pleasant and pleasing to the ears, it is not a matter of volume being too high or too low, it just feels rough and bad and I want FireFox to play it smooth too but I can't figure out why its like this for FireFox.

Modified by LovelyJane

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Helpful Reply

I've called for more help.

I've called for more help.

Question owner

Got an idea, is it possible to reset the settings to default for whatever FireFox uses to render:

format: MPEG-2 Audio 0 video stream, 1 audio stream, 0 subtitle stream

Audio Stream 0: Codec: MPEG-2 Audio Layer 3, MPEG-2A L3, bitrate 32 Kbps, bitrate mode CBR, sampling rate 22 KHz, 1 channel, resolution: 16 bits per sample

Maybe it will solve the issue? But I don't know how to do that.

Got an idea, is it possible to reset the settings to default for whatever FireFox uses to render: format: MPEG-2 Audio 0 video stream, 1 audio stream, 0 subtitle stream Audio Stream 0: Codec: MPEG-2 Audio Layer 3, MPEG-2A L3, bitrate 32 Kbps, bitrate mode CBR, sampling rate 22 KHz, 1 channel, resolution: 16 bits per sample Maybe it will solve the issue? But I don't know how to do that.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

Deleting the '''mimeTypes.rdf''' will reset all download actions to the default settings. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the above file. Then rename or delete it. Restart Firefox.

Question owner

The download actions from FireFox is not the issue, I just tested it using the same file that I used in the previous posts, I did file -> open file -> translate_tts.mp3 and get the same problem result in FireFox but it is not present if I used other players to open it mentioned in previous posts.

Anyway I just tried your mimeTypes.rdf and the problem is still there in FireFox.

Also I just found the "render mode" for FireFox from using "Tools - > Page Info" that I am having a bug with, its called "Quirks mode", text encoding UTF-8 and type audio/mpeg but the page source is not available (greyed out, clicking it does nothing but it works on other web pages when its not greyed out).

The download actions from FireFox is not the issue, I just tested it using the same file that I used in the previous posts, I did file -> open file -> translate_tts.mp3 and get the same problem result in FireFox but it is not present if I used other players to open it mentioned in previous posts. Anyway I just tried your mimeTypes.rdf and the problem is still there in FireFox. Also I just found the "render mode" for FireFox from using "Tools - > Page Info" that I am having a bug with, its called "Quirks mode", text encoding UTF-8 and type audio/mpeg but the page source is not available (greyed out, clicking it does nothing but it works on other web pages when its not greyed out).

Modified by LovelyJane

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers
Use these links to create a new profile. Use this new profile '''as is.''' Is the problem still there? '''http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder''' '''https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles''' '''https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible''' Type '''about:profiles'''<enter> in the address bar.