X
Tap here to go to the mobile version of the site.

منتدى الدعم

Outlook.com loading the 'light' desktop site, instead of the mobile site.

Posted

Just posting to report an issue on the latest version(s) of the android browser. When logging in to live.com through the browser, I'm being redirected to the 'light' version of the site - the desktop site provided to unsupported browsers.

I've tried requesting the mobile site via m.mail.live.com as per Microsofts instructions, but this did not work.

I'm able to log in and get the mobile site on chrome, but not in Firefox. I've tried clearing temporary files and the cache, but this has not solved the issue.


If i select "request desktop site" I get the "full" version of the desktop site, rather than the light version.

I'm running an xperia z3, with android 5.1

Just posting to report an issue on the latest version(s) of the android browser. When logging in to live.com through the browser, I'm being redirected to the 'light' version of the site - the desktop site provided to unsupported browsers. I've tried requesting the mobile site via m.mail.live.com as per Microsofts instructions, but this did not work. I'm able to log in and get the mobile site on chrome, but not in Firefox. I've tried clearing temporary files and the cache, but this has not solved the issue. If i select "request desktop site" I get the "full" version of the desktop site, rather than the light version. I'm running an xperia z3, with android 5.1

Modified by Drew-64

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Helpful Reply

Hi Drew-64, that's a good tip on the mobile address, and it works for me.

I noticed at the bottom of the mobile page a link to "PC Site" which displays a much less usable view. When I rotated that page to landscape and went to the bottom, the word Mobile was cut off, but I tapped Mo and it took me back to the mobile view. Can you find anything like that?

If not, that link probably sets a cookie, so you could try clearing cookies to see whether that helps.


Otherwise, how does your Firefox identify itself? If you visit this test site from your device, what user agent does it show?

https://jeffersonscher.com/res/jstest.php

For comparison, mine shows:

Mozilla/5.0 (Android; Mobile; rv:40.0) Gecko/40.0 Firefox 40.0

Note: larger screen devices may send Tablet instead of Mobile.

Hi Drew-64, that's a good tip on the mobile address, and it works for me. I noticed at the bottom of the mobile page a link to "PC Site" which displays a much less usable view. When I rotated that page to landscape and went to the bottom, the word Mobile was cut off, but I tapped Mo and it took me back to the mobile view. Can you find anything like that? If not, that link probably sets a cookie, so you could try clearing cookies to see whether that helps. ---- Otherwise, how does your Firefox identify itself? If you visit this test site from your device, what user agent does it show? https://jeffersonscher.com/res/jstest.php For comparison, mine shows: Mozilla/5.0 (Android; Mobile; rv:40.0) Gecko/40.0 Firefox 40.0 Note: larger screen devices may send Tablet instead of Mobile.

Helpful Reply

HI, thanks for your reply.

There's nothing at the bottom of the page, other than "connected to microsoft exchange" i've tried with both orientations.

I've tried clearing just the cache, and then all local files via the app -settings, and clearing private data in the app, all with no effect.

live.com was recognising the browser as a mobile previously, before they appeared to update their site.


using that link I get exactly the same report as you:

https://jeffersonscher.com/res/jstest.php

Mozilla/5.0 (Android; Mobile; rv:40.0) Gecko/40.0 Firefox 40.0

HI, thanks for your reply. There's nothing at the bottom of the page, other than "connected to microsoft exchange" i've tried with both orientations. I've tried clearing just the cache, and then all local files via the app -settings, and clearing private data in the app, all with no effect. live.com was recognising the browser as a mobile previously, before they appeared to update their site. using that link I get exactly the same report as you: https://jeffersonscher.com/res/jstest.php Mozilla/5.0 (Android; Mobile; rv:40.0) Gecko/40.0 Firefox 40.0
jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Oh, I was using the consumer version (old Hotmail address) and not a business version of the site. There is obviously a difference there.

In a Gmail thread, there was a simple switch of Table and Mobile in the user agent to get Gmail to show a mobile view on a tablet. (Firefox for Android only displays the desktop version of gmail instead of the mobile one.) However, this seems as though it will require a stronger intervention.

Could you try the "Phony" extension and tell live.com Firefox is Chrome and see whether that makes any difference? If that works well, perhaps we could engineer an override.

https://addons.mozilla.org/mobile/addon/phony/

Oh, I was using the consumer version (old Hotmail address) and not a business version of the site. There is obviously a difference there. In a Gmail thread, there was a simple switch of Table and Mobile in the user agent to get Gmail to show a mobile view on a tablet. ([https://support.mozilla.org/questions/1053476 Firefox for Android only displays the desktop version of gmail instead of the mobile one.]) However, this seems as though it will require a stronger intervention. Could you try the "Phony" extension and tell live.com Firefox is Chrome and see whether that makes any difference? If that works well, perhaps we could engineer an override. https://addons.mozilla.org/mobile/addon/phony/

Question owner

Thanks again for the reply.

I've had a play around with the Phony Add-on, and the results are a bit inconsistent.

Setting the user Agent to chrome sometimes works, and it displays the mobile site, if i then erase all data and try again, it will sometimes load everything as the desktop site, including the login page (which in firefox displayed as the mobile version) When in this state logging in will display the non-light version of the desktop site (the same i get in firefox if i select 'request desktop site').

Setting the user agent to 'Android-phone' will consistently display the mobile site.


As you mentioned, If i log into my old hotmail account, with the default user agent, I get the mobile site every time.


Thanks

Thanks again for the reply. I've had a play around with the Phony Add-on, and the results are a bit inconsistent. Setting the user Agent to chrome sometimes works, and it displays the mobile site, if i then erase all data and try again, it will sometimes load everything as the desktop site, including the login page (which in firefox displayed as the mobile version) When in this state logging in will display the non-light version of the desktop site (the same i get in firefox if i select 'request desktop site'). Setting the user agent to 'Android-phone' will consistently display the mobile site. As you mentioned, If i log into my old hotmail account, with the default user agent, I get the mobile site every time. Thanks
Rubin Bhandari 24 solutions 211 answers

Hi there please check whether you have the request destokp site checked on menu.

Hi there please check whether you have the request destokp site checked on menu.

Question owner

It's not checked

It's not checked
GavinQ 0 solutions 1 answers

Try disabling noscript. Even though I had allowed everything it still blocked several sites.

Try disabling noscript. Even though I had allowed everything it still blocked several sites.