Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

help! How do I get rid of firefox developer tools.

  • 32 uphendule
  • 21 zinale nkinga
  • 4610 views
  • Igcine ukuphendulwa ngu cor-el

more options

I am a computer dummy. Firefox is installed in our Windows 8 computer as our browser. Whenever we use it, a very annoying thing called Default Fire Fox Developer tools comes up at the bottom and takes up half our screen. Sometime it lets me hit esc. to close it but then it just pops back up. We use our computer for the net, e mail and social media alongside learning sites for our kids. How can I get rid of this thing? Please help me and explain it like I am 6 .

All Replies (20)

more options

Various Web Developer tools each have a corresponding pref on the about:config page to enable or disable them.

You can search for devtools.*.enabled via the Search bar at the top of the about:config page and set them to false.

more options

I've got the same problem, maybe even worse. I'm using the current version of FF on Win7 Pro on a fairly new and robust Dell desktop. I marked everything to do with devtools as false, restarted firefox and the computer several times, no luck.

There must be a fix for a problem that shouldn't exist. Mine seems to be the firefox developer console, maybe the same as above. The console pops up randomly, whether I'm browsing, clicking on articles to read, or writing this message.

The console is now empty, since everything is marked false, but I can fill it by checking the boxes in the first tab.

Some letters that seem to trigger the console include o, i, p, l, comma, ], /, ' and return. But not always. Makes me wonder if shortcuts could be involved.

Suggestions will be much appreciated.

more options

Hi RenoBill, do you mean the one labeled Browser Console that opens in a separate window? The normal keyboard shortcut for that is Ctrl+Shift+j, which doesn't match any of the keys giving you problems. The Web Console, which normally opens in the lower part of the same tab, is assigned to Ctrl+Shift+k, which again doesn't match anything you're typing.

Have you tested in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any change?

more options

I reset FF and reloaded only add-ons that I've used for at least 6 months, so they are very unlikely to cause this problem. It's still there, the console shows up unexpectedly and usually cannot be closed. Any further ideas?

I'm about to uninstall/reinstall FF, hopefully that will work.

more options

Make sure to delete the Firefox when you uninstall Firefox.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

Try going to your 'TOOLS" menu toolbar at the top of your FF browser, go down to "Web Developer", then click on "Toggle Tools". Did this help?

more options

If this doesn't help go to the 'Tools' menu and click on 'Add-ons', go to 'Extensions' and scroll down until you see 'Web Developer Tools 1.2.5' click on 'disable' or 'Remove'

more options

wwknight2: Toggle Tools brings up the console, so no help. Thx anyhow.

more options

wwknight2: I don't have that extension. Too bad, that would be an easy fix.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Go back and click it again this will make the console go away

more options

Problem still exists in safe mode. I'm going to uninstall/reinstall FF to see if that works.

more options

The toggle switch works fine. But the console still pops up for no apparent reason. Reinstall FF is my next step.

more options

Still no success. I uninstalled/reinstalled firefox twice, opened several times in safe mode, reset firefox, set all devtools entries to false, the console now pops up all the time, even worse than before.

In about:config, one entry says: DEVTOOLS.TELEMETRY.TOOLS.OPENED.VERSION.

It's a user set string with the following value: {"DEVTOOLS_WEBCONSOLE_OPENED_PER_USER_FLAG":"25.0.1","DEVTOOLS_OPTIONS_OPENED_PER_USER_FLAG":"25.0.1","DEVTOOLS_RESPONSIVE_OPENED_PER_USER_FLAG":"25.0.1","DEVTOOLS_SCRATCHPAD_OPENED_PER_USER_FLAG":"25.0.1"}

I deleted the value, but that didn't help.

There may be two consoles, one that opens on top of the screen, another that opens on the bottom. I get both.

Any ideas?

more options

Hi RenoBill, I know you said the console opens unexpectedly.

Can you discover any pattern to what sites cause the console to open?

Which section is usually displayed (there are different sections in the tools that open in the lower part of the tab: Console, Inspector, Debugger, and so forth)?

Can you associate the console opening with particular actions that took place immediately before, such as a page loading, clicking a link, right-clicking, etc.?

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

There's no rhyme or reason as to when the console opens. Sometimes the console is on top, other times on the bottom - maybe different consoles. Worst is when typing, like now. But also randomly when browsing.

Console is empty since values are all false.

What would happen if I deleted all registry entries for devtools?

Is there any way to remove devtools and/or the console from firefox?

While typing in this window, letter o is worst, frequently bringing up the console. also ', p,-, back space, return, and even prt scn, all intermittently. Right now it's ok, after closing it dozens of times. Sometimes it won't close until clicked 5-10 times, or even forcing me to exit FF.

Since it's behaving for the moment (this has happened in the past, but only for a while), no screenshot right now.

more options

If it happens again then please make a screenshot and attach it to a reply to make sure that we understand correctly what is happening.

more options

Might or might not be relevant: in the following thread, this problem was fixed by replacing the batteries in the keyboard. Turn off web developer.

more options

Here's a screenshot. Empty because all entries are false. Other times it (or a similar one) appears at the bottom.

  1. 1
  2. 2