Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Sometimes FF loses FPS and starts working very choppy.

  • 4 uphendule
  • 5 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu user686414

more options

From time to time the browser starts working at very low FPS - smooth scrolling gets very choppy, typing in a text box shows the characters with a delay, minimizing/maximizing the FF window is also not smooth. I need to restart FF to make it work smooth again. I have this problem on multiple PCs - the only common thing is the CPU/GPU - Intel/NVIDIA. Tried Safe Mode, resetting FF - doesn't help - at random intervals it just drops to very low FPS. All plugins are up to date, all drivers are the latest. FF 23.0.1. It's as if there is an incompatibility between FF and my machines but can't find where.

From time to time the browser starts working at very low FPS - smooth scrolling gets very choppy, typing in a text box shows the characters with a delay, minimizing/maximizing the FF window is also not smooth. I need to restart FF to make it work smooth again. I have this problem on multiple PCs - the only common thing is the CPU/GPU - Intel/NVIDIA. Tried Safe Mode, resetting FF - doesn't help - at random intervals it just drops to very low FPS. All plugins are up to date, all drivers are the latest. FF 23.0.1. It's as if there is an incompatibility between FF and my machines but can't find where.

All Replies (4)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

With or without hardware acceleration the problem persists. Disabling WebGL didn't help. All my drivers are up to date, but the random drops in FPS keep happening (it's not just the smooth scrolling that's affected, all activities in FF become very choppy (like open new tab, minimize window, etc...)).

more options

Can you reproduce in a new profile?

If the new profile works properly, transfer some files from the old one to the new one, see the Recovering important data from an old profile article.

more options

Thanks, that reduced the problems quite a lot. I still get the random FPS drops, but much more rarely.