Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I stop Firefox clicking when I select an option from a drop-down menu? It's bloody annoying.

  • 11 uphendule
  • 2 zinale nkinga
  • 34 views
  • Igcine ukuphendulwa ngu scm1

more options

When I select an option from the pull-down menus, or a link from right-clicking on the forward or back buttons, it makes a click sound. I'm using this on a machine that I use for recording and I don't want clicks on my soundtrack. How can I turn it off - I've looked through about:config and preferences but haven't seen any way to select or disable such a feature. I'm using FF 8.0 on Ubuntu Studio.

Isisombululo esikhethiwe

Thanks again for your persistence. :-)

I've managed to quieten things down by selecting the "No sounds" Sound theme under System->Preferences->Sound, which isn't ideal as it's not specific to FF, but I'd rather not have spurious sounds impinging on my recordings, so it'll do for me!

FYI, reducing the sound level to minimum had no effect - I had to select the "No sounds theme".

Thanks again for all who contributed, it's much appreciated.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (11)

more options

Hi,

It could be a Ubuntu Studio sound preference. You may have to turn off mouse click sound effects in the system.

...............................................................................................................................

Useful links:

All about Tools > Options

Going beyond Tools > Options - about:config

about:config Entries

Page Info Tools (Alt + T) > Page Info, Right-click > View Page Info

Keyboard Shortcuts

Viewing Video without Plugins

Firefox Profile Folder & Files

Firefox Commands

Basic Troubleshooting

After Upgrading

Safe Mode

Problematic Extensions

Troubleshooting Extensions and Themes

Troubleshooting Plugins

Testing Plugins

more options

Thanks for the reply, but I don't think it's right. I can't find any option in the system to enable clicks only on FF drop-down options (I couldn't actually find any options to do with mouse-clicks, any clues as to where to look?). I don't get the click on anything else, which I'd expect if it was system-wide. Any other ideas? I'd quite like this version of FF, if only I could get it to shut up!

more options

Firefox comes with one sound, for the Find bar. Any other sounds in Firefox would be from an add-on or from the operating system.

http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

more options

I'm using the default theme, no add-ons and have disabled both the extensions that are installed, and the click is still there. I'll have another look for a mouse click option in the system that only affects the FF drop-downs, but I'm not hopeful. Thanks for your help so far.

Okulungisiwe ngu scm1

more options

Please also see this. Looks like a similar issue but in Ubuntu 10.10.

more options

Not certain about Ubuntu, but in Windows and in several Linux Os there is a sound option that is located in the control panel/system preferences

you'll see sound options for various programs.. including drop down and flyout menus. That may be where your sound is coming from.

Is Firefox drop down menu the only thing making noise for you?

more options

Thanks for the suggestions - I've tried the 10.10 link but couldn't find a sound that matched the FF click, also FF is the only app that behaves this way - other windows are wonderfully silent when I click their drop-down options. I've also disabled system alert sounds (and set the volume to minimum to make sure!), but FF still gives me those when I type an invalid URL, so it seems to be independent of the underlying OS.

I guess I'll have to live with it and hope it gets "fixed" (or at least makes public a "shut-up" option) in a future release.

Okulungisiwe ngu scm1

more options

You can set the volume slider for the System Sounds to zero in the GNOME (PulseAudio Volume Control).

more options

Yeah, see where I said "(and set the volume to minimum to make sure!)" in my previous post? But it makes no difference.

more options

Here's something. The customized Firefox (not the official Mozilla Firefox) in Ubuntu (and possibly Ubuntu Studio, Kubuntu etc.) may indeed have sound effects independent of the system sound settings. The above link is a slightly different issue and I think it's for the Unity interface, so you may have to dig a little deeper (in Ubuntu Firefox?, system sound prefs?, in the file system?). I think Ubuntu users may be able to help. Please do post the results.

more options

Isisombululo Esikhethiwe

Thanks again for your persistence. :-)

I've managed to quieten things down by selecting the "No sounds" Sound theme under System->Preferences->Sound, which isn't ideal as it's not specific to FF, but I'd rather not have spurious sounds impinging on my recordings, so it'll do for me!

FYI, reducing the sound level to minimum had no effect - I had to select the "No sounds theme".

Thanks again for all who contributed, it's much appreciated.

Okulungisiwe ngu scm1