Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My operating system doesn't support Firefox 4.0, why don't you post system requirements when sending out new versions? Or don't you care about those of us that can't afford new technologies?

  • 4 uphendule
  • 24 zinale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu uggabugga

more options

I was prompted to download Firefox 4.0 and when I did and tried to open it I got an error message saying "You cannot open this application "Firefox" beacause it is not supported on this system. I have an older version of Mac OS X, 10.4.11, so I'm guessing that is the problem. Please direct me to where I can download an older version of Firefox that my system can support and next time please include system requirements with your update prompts.

I was prompted to download Firefox 4.0 and when I did and tried to open it I got an error message saying "You cannot open this application "Firefox" beacause it is not supported on this system. I have an older version of Mac OS X, 10.4.11, so I'm guessing that is the problem. Please direct me to where I can download an older version of Firefox that my system can support and next time please include system requirements with your update prompts.

All Replies (4)

more options

For older Macs that aren't supported in Firefox 4.0, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

more options

The failure to post system requirements is inexcusable. It cost me a lot of wasted time and effort, and in the end, I had to re-download and re-install version 3.6.16. The entire problem could have been avoided if you had just posted the system requirements in the first place. This experience has undermined my trust in the entire Mozilla operation.

more options

Thank you for posting that link the-edmiester. I have already re-downloaded firefox 3.6.16 but will give tenfourfox a try. However, not to point the finger at you edmiester, my original question has still not been answered. Is it too much to ask for system requirements when I am prompted to download a new version of Firefox? I realize my computer is out of date and the longer I have it the less I'll be able to use it in this brave new internet world and I don't expect Mozilla to continually pander to me and others like me by keeping there web browsers compatible with older machines but I am fine with using older versions of Firefox. 3.6 works fine and when I saw that there was an update I thought "cool a newer version that would logically work better and faster than the one I was using" but that was clearly not the case. Like Redbeard I was forced to find an older version, re-download and re-install. Luckily I still had Safari, I shutter to think what would have happened if I had deleted it. As well, like Redbeard, this totally undermines my confidence in Firefox and I would hope that Mozilla cares enough about their users, you know the ones that create the need for their jobs, to at least address things like this in a timely respectful fashion.

more options

I not only can't use 4 (I'm also 10.4.11) but now it won't let me redownload 3.6.16. Guess I'm stuck with safari. pffft.