Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My Homepage opens in Japanese. How do i change it to open in English?

  • 2 uphendule
  • 138 zinale nkinga
  • 3333 views
  • Igcine ukuphendulwa ngu ruffled

more options

I have just downloaded UK version from http://www.mozilla-europe.org/en/firefox/ . My homepage shows Japanese text only - I am currently in Japan so I assume Firefox shows Japanese by default - but I want English. How to make it default to English? Homepage address is http://www.google.co.jp/firefox?client=firefox-a&rls=org.mozilla:en-GB:official

This happened

Every time Firefox opened

== From installation

All Replies (2)

more options

Isisombululo Esikhethiwe

more options

my tour page opens in French ... down loaded 3x .. the last specifically uk english ... reckon it`s back to IE 8 !