Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blank buttons on toolbars

  • 8 uphendule
  • 0 zinale nkinga
  • 47 views
  • Igcine ukuphendulwa ngu noel_envode

more options

It's been a while, but I've seen this before. What causes this? Can i prevent it? The blank icons also appear next to the most of the affected addons in about:addons.

I was able to restore normality, at least for the moment, by disabling those addons, re-enabling, then restarting.

It's been a while, but I've seen this before. What causes this? Can i prevent it? The blank icons also appear next to the most of the affected addons in about:addons. I was able to restore normality, at least for the moment, by disabling those addons, re-enabling, then restarting.
Ama-screenshot ananyekiwe

Okulungisiwe ngu noel_envode

All Replies (8)

more options

Does it happen with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#

What theme is that?

Helpful?

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Helpful?

more options

jonzn4SUSE said

Does it happen with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode# What theme is that?
I don't know. In the future, I'll try clearing the cache to see if that helps.


I "solved" the problem for a few of the apps by disabling/enabling them, and re-pinning them, but for most, I had to drag and drop their .xpi's into the browser.

BTW, when posting here, I run into line spacing issues. I never know how it manifests until I post. We can see that double-space above. There is no adjustment. I'ts either that, or no space at all. Is that just me?

Okulungisiwe ngu noel_envode

Helpful?

more options

Are you using userChrome.css/userContent.css ?

Helpful?

more options

cor-el said

Are you using userChrome.css/userContent.css ?
I use CustomCSSforFx. The latest, unaltered version, about a month old, was in effect before, and currently.


I assume your wondering if that caused or contributed to the issue? All I can say is that the scripts were in place long before, and the are are included in several other profiles that don't reflect the same behavior.

I updated to Firefox 121.0 on 12/20. Frankly, I don't remember if the problem arose after that update, but I'm fairly confident I would have noticed the coincidence. I posted here on 12/23. I don't think I waited 3 days to report it. In any case, if there was of conflict or incompatibility with css, I don't see how my simple workaround would have had an effect on reversing the mess.

Okulungisiwe ngu noel_envode

Helpful?

more options

cor-el said

Are you using userChrome.css/userContent.css ?
Yes. Maybe I'm wrong, but I don't see how that could be a factor. The scripts haven't been altered for a month.

I did update to Fx 121.0 on 12/20. I "think" I would have noticed the coincidence. In any case, If there was some sort of conflict in compatibility, I don't see how my simple workarounds would have had an effect.

Helpful?

more options

Did you try to clear the startup cache like I suggested above ?

Helpful?

more options

Sorry for that redundant post, but I thought the first one had been removed somehow. I went away and when I came back, I couldn't find it.

cor-el said

Did you try to clear the startup cache like I suggested above ?
I did the workaround that restored things before I saw your suggestion. In the future, I'll make that part of my problem solving routine.

Just curious, have you seen blank buttons like that before. Did clearing the cache fix it?

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.