Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Multiple speakers - one not visible in Google Meet but

  • 3 uphendule
  • 0 zinale nkinga
  • 9 views
  • Igcine ukuphendulwa ngu constantine1

more options

I have two audio devices for audio output (speakers) on my PC. One is for music and the other is a Jabra device for conferences. When using Google Meet, only one of the devices is available to me (the music speakers). What is strange is that when I am using Zoom or Teams both devices are available and selectable.

Echo cancellation would be better if I could use the Jabra device for Google Meet calls.

I am using Firefox / Windows 11 (Version 10.0.22621 Build 22621).

Thanks in advance!

I have two audio devices for audio output (speakers) on my PC. One is for music and the other is a Jabra device for conferences. When using Google Meet, only one of the devices is available to me (the music speakers). What is strange is that when I am using Zoom or Teams both devices are available and selectable. Echo cancellation would be better if I could use the Jabra device for Google Meet calls. I am using Firefox / Windows 11 (Version 10.0.22621 Build 22621). Thanks in advance!

Isisombululo esikhethiwe

By default, Firefox hides audio output devices from pages. There is a privacy-related reason for this, but I honestly can't remember exactly what it is. If you want to make output devices visible to websites, here's how to you can do it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste media.setsinkid.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

You probably need to reload the page or revoke and re-grant permissions after that before noticing any change.

Does that work on Google Meet?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

I should have added that for the audio input (microphone) multiple devices are correctly shown (see screenshot).

Also, this is a Firefox issue. On Edge, I can see multiple devices.

Helpful?

more options

Isisombululo Esikhethiwe

By default, Firefox hides audio output devices from pages. There is a privacy-related reason for this, but I honestly can't remember exactly what it is. If you want to make output devices visible to websites, here's how to you can do it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste media.setsinkid.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

You probably need to reload the page or revoke and re-grant permissions after that before noticing any change.

Does that work on Google Meet?

Helpful?

more options

This is fantastic, thank you so much!!!

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.