Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Websites don't display their contents properly, they work fine in Private Mode

  • 2 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu cor-el

more options

Firefox was working properly then suddenly this started happening. Certain sites refuse to display properly, and sites like youtube don't even let me log in because when I click certain things they don't do anything. I looked up numerous fixes and they did nothing.

Tried Troubleshoot mode and the issue persisted.

Deleted cookies and cache, allowed them for all sites and disabled Enhanced Tracking Protection and it didn't solve the issue.

I couldn't even log in to this site because it kept saying "Cookies and local storage are required" even though I'm pretty sure they are enabled, I had to log in in Private Mode just to get the site working. Private mode for some reason has no issues and all the sites that don't work appear fine when I use it.

Firefox was working properly then suddenly this started happening. Certain sites refuse to display properly, and sites like youtube don't even let me log in because when I click certain things they don't do anything. I looked up numerous fixes and they did nothing. Tried Troubleshoot mode and the issue persisted. Deleted cookies and cache, allowed them for all sites and disabled Enhanced Tracking Protection and it didn't solve the issue. I couldn't even log in to this site because it kept saying "Cookies and local storage are required" even though I'm pretty sure they are enabled, I had to log in in Private Mode just to get the site working. Private mode for some reason has no issues and all the sites that don't work appear fine when I use it.

All Replies (2)

more options

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_the-problem-happens-in-troubleshoot-mode If the problem still happens in Troubleshoot Mode, it is not being caused by an extension or theme. Other possible causes include changes made to Firefox preference settings, which are not disabled in Troubleshoot Mode. See the following articles for solutions:

https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems

You might save a lot of time if you try a new profile. https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

Helpful?

more options

Note that not all extensions work by default in PB mode.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.