Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Widevine plugin creashes all streaming sites

  • 6 uphendule
  • 1 inale nkinga
  • 24 views
  • Igcine ukuphendulwa ngu James

more options

For the past week, when I login any streaming services (Netflix, Hulu, etc) I get a message "Gah, your tab just crashed". After going through every add-on and plugins I found that 'Widevine Content Decryption Module provided by Google Inc' causes this. Disabling widevine allows the tabs to load but then I get a request to enable DRM to play the videos and if I do it just enables widevide again and the tab crashes. I never had this issue before. Is there a different plugin I can use or a way around the DRM request? Widevine version is the latest is updated.

For the past week, when I login any streaming services (Netflix, Hulu, etc) I get a message "Gah, your tab just crashed". After going through every add-on and plugins I found that 'Widevine Content Decryption Module provided by Google Inc' causes this. Disabling widevine allows the tabs to load but then I get a request to enable DRM to play the videos and if I do it just enables widevide again and the tab crashes. I never had this issue before. Is there a different plugin I can use or a way around the DRM request? Widevine version is the latest is updated.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

The Widevine plugin is the only way to play DRM protected content.

Maybe try the current Nightly that can use Widevine 4.10.2449.0 to see whether that version behaves better.

  • 1758421 - [Meta] Update Widevine to 4.10.2449.0
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Plugins/Addon issue support is provided by the Addon Developer not from Firefox. Forum help doesn't provide DRM circumvention that get's into thorny legal issues.

Helpful?

more options

Isisombululo Esikhethiwe

The Widevine plugin is the only way to play DRM protected content.

Maybe try the current Nightly that can use Widevine 4.10.2449.0 to see whether that version behaves better.

  • 1758421 - [Meta] Update Widevine to 4.10.2449.0

Helpful?

more options

I still don't know what's causing it to fail. It is up to date with the latest version and I could not find support for end users anywhere. It works on Nightly though. Thank you.

Helpful?

more options

Is there anything in the Browser Console about the Widevine crashes ?

Helpful?

more options

I couldn't find anything about widevine in the browser console. I tried downloading a previous version and replacing the documentation in the profile folder gmp-widevinecdm but firefox won't recognize it. I get a message saying it'll be installed soon but nothing happens unless I click in updates in the add-ons tab, then I get the crashing version.

Helpful?

more options

Dropa said

Plugins/Addon issue support is provided by the Addon Developer not from Firefox.

The Firefox web browser from mozilla.org comes with the Widevine Plugin. https://support.mozilla.org/en-US/kb/enable-drm

This is not a NPAPI Plugin and they are no longer supported. https://support.mozilla.org/en-US/kb/npapi-plugins

Addons is a general term that groups together the separate Extensions, Themes, Dictionaries, Language Packs, Themes, Search Engines.

Okulungisiwe ngu James

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.