On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Site isolation" seems to make me click the back button multiple times on pages with embedded YouTube videos

  • 7 uphendule
  • 1 inale nkinga
  • 4 views
  • Igcine ukuphendulwa ngu jpawlick4

more options

I am currently creating a website in WordPress. It has many embedded YouTube videos.

On pages with embedded YouTube videos, in order to go back to the previous page, I have to click the Back button multiple times. If I right-click on the back button, I see that the page I am currently on has been listed multiple times.

Many other support questions list this issue. I have found that if I disable "Site Isolation" (URL about:config -> set fission.autostart to false -> restart Firefox), the issue goes away.

I am interested, however, in the user experience for those who will go to my site. Is there anything I can do so that "Site Isolation" does not cause this problem?

Thanks, Jeff

I am currently creating a website in WordPress. It has many embedded YouTube videos. On pages with embedded YouTube videos, in order to go back to the previous page, I have to click the Back button multiple times. If I right-click on the back button, I see that the page I am currently on has been listed multiple times. Many other support questions list this issue. I have found that if I disable "Site Isolation" (URL about:config -> set fission.autostart to false -> restart Firefox), the issue goes away. I am interested, however, in the user experience for those who will go to my site. Is there anything I can do so that "Site Isolation" does not cause this problem? Thanks, Jeff

Isisombululo esikhethiwe

I found a solution that works for me!

When you generate the embed code on YouTube.com, you can select "Use privacy-enhanced mode." This changes the link within the embed code from "https://www.youtube.com/embed/..." to "https://www.youtube-nocookie.com/embed/"

Using this new code on my WordPress site, I no longer have to hit the back button twice, and if I right-click on the back button I just see one instance of each page, as should be the case.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

Did you also contact WordPress since is the site your using to create the website.

Helpful?

more options

In case it helps, the temporary version of my site is https://stgronli-cp708.wordpresstemporal.com/. You should be able to verify the issue without logging in. For instance, on the top menu bar, click "Noticias." Then click "Home." If you right-click the back-button, both are listed multiple times (at least for me).

Helpful?

more options

@DontHaveCow: Update - Yes, I have now also asked Wordpress. Waiting for a reply. But I think Mozilla will have the best perspective to help answer the question.

Okulungisiwe ngu jpawlick4

Helpful?

more options

I just tested with Fission off and had to click multiple times to go back on Linux. I cleared my cache and restarted the browser before testing.

Okulungisiwe ngu jonzn4SUSE

Helpful?

more options

Here is a video of my desktop showing the issue. I have the same issue with Fission on or off.

https://youtu.be/3nMgOmyqnWI

Helpful?

more options

I also ran a test in Troubleshoot mode with no issues going back. Someone more Dev savvy will have to chime in.

Okulungisiwe ngu jonzn4SUSE

Helpful?

more options

Isisombululo Esikhethiwe

I found a solution that works for me!

When you generate the embed code on YouTube.com, you can select "Use privacy-enhanced mode." This changes the link within the embed code from "https://www.youtube.com/embed/..." to "https://www.youtube-nocookie.com/embed/"

Using this new code on my WordPress site, I no longer have to hit the back button twice, and if I right-click on the back button I just see one instance of each page, as should be the case.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.