Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Dark mode starts even though it's disabled in Themes

  • 2 uphendule
  • 2 zinale nkinga
  • 41 views
  • Igcine ukuphendulwa ngu saraw1

more options

Since upgrading to 95.0, random pages are being displayed in dark mode.

It's a page level problem: the home page of a site like mlb.com displays correctly, but interior pages of that same site don't (example: https://www.mlb.com/news/mlb-all-batting-stance-team).

Oddly, some interior pages of sites are rendering in dark mode while others don't. To continue with the mlb.com example above, here's an interior page that does not come up in dark mode: https://www.mlb.com/news/featured/baseball-road-trip-locations-in-all-50-states-and-ontario

I have disabled the dark mode theme; that doesn't solve the problem.

In Colors, I have set Text to Black. Background is White.

That doesn't solve the problem.

Also in Colors, I've tried all three options listed in "Override the colors specified in the page". None of them fix it.

All of this is on Windows 10, 64 bit, OS build 19043.1348.

FWIW, this problem doesn't happen if I use FF on an IOS device.

It also doesn't happen with any other browsers I test, like Chrome, Edge, or Brave.

How can I eliminate dark mode?

Since upgrading to 95.0, random pages are being displayed in dark mode. It's a page level problem: the home page of a site like mlb.com displays correctly, but interior pages of that same site don't (example: https://www.mlb.com/news/mlb-all-batting-stance-team). Oddly, some interior pages of sites are rendering in dark mode while others don't. To continue with the mlb.com example above, here's an interior page that does not come up in dark mode: https://www.mlb.com/news/featured/baseball-road-trip-locations-in-all-50-states-and-ontario I have disabled the dark mode theme; that doesn't solve the problem. In Colors, I have set Text to Black. Background is White. That doesn't solve the problem. Also in Colors, I've tried all three options listed in "Override the colors specified in the page". None of them fix it. All of this is on Windows 10, 64 bit, OS build 19043.1348. FWIW, this problem doesn't happen if I use FF on an IOS device. It also doesn't happen with any other browsers I test, like Chrome, Edge, or Brave. How can I eliminate dark mode?

All Replies (2)

more options
more options

@mitch11 -

I had the exact same problem you are describing, until just a moment ago. Here's what worked for me: I went into Settings, but did not look at extensions or themes. Instead, in General/Language and Appearance, I clicked on "Colors." I did not change use the theme I now use, which is light. In the drop-down menu within that section, a choice was presented about under what conditions the program could change my choices: I tried all three, but "Only with high-contrast themes" seemed to accomplish the end I wanted: doing away with "dark mode," which I do not like at all.

BTW, I am using a 2019 Macbook Pro, 16", OS 12.2 Monterey, Firefox 96.0.3.

Hope this helps!