Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Links?

  • 2 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu jscher2000

more options

every time I try to type something in the address bar I get this message you were trying to open http:// ? I'm using the latest version, how can I remove it? I've turned off the search suggestions but nothing. why this happen?

Ama-screenshot ananyekiwe

Okulungisiwe ngu Eyras

All Replies (2)

more options

People get this sort of problem using the address bar for searching. You can choose to use a separate search bar on the Home page of options.

Helpful?

more options

Hi, when you run a single word search, Firefox checks in the background whether there is a server at that address. This is useful to find servers on your internal network, such as http://intranet/.

If you get this bar all the time, it usually indicates that your current DNS service provider is dishonest. An honest DNS will tell Firefox your query text is not a known hostname. But dishonest DNS services will send Firefox an address of a server that hosts pay-per-click advertising to "help" you find what you're looking for. Perhaps you've seen such a page if you ever typo'd an address.

(If you are using DNS over HTTPS, Firefox still may check with Windows for single word queries or other host names that aren't found on the web.)

With that in mind, here are two options:

(1) Investigate the root of the problem and disable it or opt out of it (could take some work) (2) Set Firefox not to search single words as host names (quick)

Disciplining your DNS

I generally suggest trying something like:

http://no-way-this-exists/

If you get a page of search results, check for a link near the upper right or at the bottom like:

  • Opt out
  • Why am I getting this page

That usually leads to information on who/what is causing the problem and how to disable this function.

Don't check DNS

If you don't have the energy to address the DNS provider angle, this could be good enough for you for now.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste singlewords and pause while the list is filtered

(3) Double-click the browser.urlbar.dnsResolveSingleWordsAfterSearch preference to display an editing field, and change the value from 1 to 0 then press Enter or click the blue check mark button to save the change.

For reference:

  • 0 = never check
  • 1 = check in certain cases (default)
  • 2 = always check

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.