Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Vertical Scrollbar Too Small Issues

  • 3 uphendule
  • 1 inale nkinga
  • 40 views
  • Igcine ukuphendulwa ngu cor-el

more options

My vertical scroll bar is very thin, barely even visible, like 4 pixels thick. The problem is the same as already posted in these forums, both solutions were only temporary solutions. I'll state them here for simplicity:

a) The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userContent.css (name is case sensitive). Paste in "*{scrollbar-color:auto!important; scrollbar-width:auto!important;}"

This worked but then some scroll bars were extremely thick, and even showed while watching YouTube videos.

b) Clearing the startup cache.

Again, this did seem to work, but only temporarily. I removed the file from step a) and it remained fine until a day or two later.

~

Firefox Version 88.0 (64-bit), Windows 10 v10.0.19041 Using screen extension with HDMI. Problem happens on both screens. Pages that this occurs on seem to be random, increasing over time. The page I'm writing this question on included. Thanks for reading and helping.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Websites can define their own scroll bars and it is possible that you experience this.

There are some prefs on the about:config page, but most are for Linux (widget.non-native-theme.gtk). You can try these:

  • widget.non-native-theme.scrollbar.size
  • widget.non-native-theme.win.scrollbar.use-system-size

You can also code in userContent.css for webpages to prevent websites from modifying the scrollbars.

userContent.css:

* { scrollbar-color: auto! important; scrollbar-width: auto !important; }

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

I am fiddling around with the second option. Currently, the bars are regular width. I am not sure if this is simply auto. To me, auto seems to imply either regular or thin, whatever the web page indicates. There should be a 'regular' or 'full' option added. Anyways, I changed it to thin, and it did not implement this. So I am still stuck...

Helpful?

more options

Hmm, do your displays have a different effective resolution (considering native resolution and system-level scaling)? Resolution changes can cause glitches with various aspects of window layout. Perhaps that is what clearing the startup cache helps with.

If that is the problem, I don't think a style rule can fix it...

Helpful?

more options

Isisombululo Esikhethiwe

Websites can define their own scroll bars and it is possible that you experience this.

There are some prefs on the about:config page, but most are for Linux (widget.non-native-theme.gtk). You can try these:

  • widget.non-native-theme.scrollbar.size
  • widget.non-native-theme.win.scrollbar.use-system-size

You can also code in userContent.css for webpages to prevent websites from modifying the scrollbars.

userContent.css:

* { scrollbar-color: auto! important; scrollbar-width: auto !important; }

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

Helpful?

more options

Yes, I have 2 different resolutions (1920x1080 & 3840x2160, at 100% & 300%, respectively), but I have been using this setup for a year now, and I have just recently been noticing this. As far as setting toolkit.legacyUserProfileCustomizations.stylesheets = true, I did not have that. I will see if that fixes things.

EDIT: I believe it did fix things. In addition, I use this addon, which makes it so I don't have to fix the problem via the code way manually. However, the last line of code you gave allowed it to start working (maybe he will fix that in the future, as I did post all of this on his forum here ). Thanks.

Okulungisiwe ngu tomi.fodor

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.