Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have been having major issues with 68.0.2 YouTube no longer works and I have to often open several new tabs in order to get Google search to work help.

  • 1 baphendule
  • 3 zinale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu WMagicModel

more options

After the most recent Firefox update (68.0.2) I have not been able to view YouTube. I understand that Google is always making changes to YouTube. However, it work with all other browsers (Chrome (of course), Edge, and Opera) but not Firefox. In addition, sometime I have to open three or four tabs to get Google search to work. Again, this is probably a Google/Firefox issue, but it should not take so long to fix. About ready to give up on Firefox, and that is kind of sad.

All Replies (1)

more options

Hi jdbranch,

Sorry to hear you're having issues with Firefox while watching YouTube. I wanted to reach out to make sure you got this working if you haven't already.

There have been reports where Unchecking, Use hardware acceleration when available solved the issue with YouTube not working.

To do this :

  1. Click on the menu '3-bar' on your Firefox browser
  2. Click Options
  3. In General, under Performance check-mark Use recommended performance settings instead of Use hardware acceleration when available.

Reference thread : Youtube won't play on Firefox but will on other browsers {link}

I hope you're able to watch YouTube as intended!

As far as troubleshooting the Google search not working, you could try to restart in Safe Mode.

To do this :

  1. Click on the menu '3-bar' on your Firefox browser
  2. Click Help
  3. Click Restart with Add-ons Disabled
  4. Click Restart
  5. Click Start in Safe Mode

If you have no issues using the search function in Safe Mode; I would suggest this could be related to an Add-on causing issues which you could disable/remove if necessary in the about:addons or try clearing your Data in about:preferences#privacy

Warning! "Clearing all cookies and site data stored by Firefox may sign you out of websites and remove offline web content. Clearing cache data will not affect your logins."

Okulungisiwe ngu WMagicModel