X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Password Manger is not saving password

Kuphostiwe

I am running Thunderbird 60.7.2 on Mac High Sierra 10.13.6. Whenever I start Thunderbird I am prompted for "Authentication Required", user name and password. When I enter the correct user name and password my calendar entries show up. However, even after checking "Use Password Manager to remember this password", the password is not remembered and I have to enter it again the next time I start Thunderbird. I've verified that Config:signon.rememberSignons is True. Per a different thread I deleted <profileDir>/key4.db. The other file recommended to delete was logins.json but I do not have that file. After just now entering the password again, I checked Preferences > Security > Saved Passwords and the file is empty.

As an experiment, I copies the logins.json file from another Mac computer, set ownership properly and tried again. Preferences > Security > Saved Passwords still shows as empty and the contents of logins.json remains unchanged.

I am runinng Thunderbird on 2 other Mac computers, 3 Linux computers and 6 Windows 7 computer and none of the others have this problem.

How do I fix this?

I am running Thunderbird 60.7.2 on Mac High Sierra 10.13.6. Whenever I start Thunderbird I am prompted for "Authentication Required", user name and password. When I enter the correct user name and password my calendar entries show up. However, even after checking "Use Password Manager to remember this password", the password is not remembered and I have to enter it again the next time I start Thunderbird. I've verified that Config:signon.rememberSignons is True. Per a different thread I deleted <profileDir>/key4.db. The other file recommended to delete was logins.json but I do not have that file. After just now entering the password again, I checked Preferences > Security > Saved Passwords and the file is empty. As an experiment, I copies the logins.json file from another Mac computer, set ownership properly and tried again. Preferences > Security > Saved Passwords still shows as empty and the contents of logins.json remains unchanged. I am runinng Thunderbird on 2 other Mac computers, 3 Linux computers and 6 Windows 7 computer and none of the others have this problem. How do I fix this?

Okulungisiwe ngu Mark Foley

Isisombululo esikhethiwe

If it was copied from Windows, deleting pkcs11.txt from the profile folder would resolve the passwords not being saved. It won't do any harm to try it, as it is automatically recreated when TB restarts.

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno
sfhowes
  • Top 10 Contributor
1438 izisombululo 6814 izimpendulo
Kuphostiwe

Did you copy the current profile on the Mac from another TB setup on a Windows computer?

Did you copy the current profile on the Mac from another TB setup on a Windows computer?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Possibly. If so that was 7 months ago, so I don't recall. If so, is there some remedy?

Possibly. If so that was 7 months ago, so I don't recall. If so, is there some remedy?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1438 izisombululo 6814 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

If it was copied from Windows, deleting pkcs11.txt from the profile folder would resolve the passwords not being saved. It won't do any harm to try it, as it is automatically recreated when TB restarts.

If it was copied from Windows, deleting pkcs11.txt from the profile folder would resolve the passwords not being saved. It won't do any harm to try it, as it is automatically recreated when TB restarts.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

That may have done it! I'll try a few more times over the next 24 hours to make sure, but this time, after deleting the pkcs11.txt file and reentering the credentials, it DID NOT ask for id/pw after restarting. Fingers crossed.

That may have done it! I'll try a few more times over the next 24 hours to make sure, but this time, after deleting the pkcs11.txt file and reentering the credentials, it DID NOT ask for id/pw after restarting. Fingers crossed.

Okulungisiwe ngu Mark Foley

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

OK, that seems to have done the trick. Brilliant! Thanks. I would have NEVER figured that out on my own. I hope this tip can help others. I'll save this for my future reference.

OK, that seems to have done the trick. Brilliant! Thanks. I would have NEVER figured that out on my own. I hope this tip can help others. I'll save this for my future reference.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
emmryss 0 izisombululo 7 izimpendulo
Kuphostiwe

I'm having this problem on Windows 7. Where do I find pkcs11.txt?

I'm having this problem on Windows 7. Where do I find pkcs11.txt?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1438 izisombululo 6814 izimpendulo
Kuphostiwe

emmryss said

I'm having this problem on Windows 7. Where do I find pkcs11.txt?

Select Help/Troubleshooting Information, click Open Folder to open the profile folder in Explorer, close TB, delete pkcs11.txt from the profile folder.

''emmryss [[#answer-1238862|said]]'' <blockquote> I'm having this problem on Windows 7. Where do I find pkcs11.txt? </blockquote> Select Help/Troubleshooting Information, click Open Folder to open the profile folder in Explorer, close TB, delete pkcs11.txt from the profile folder.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Here: \Users\userid\AppData\Roaming\Thunderbird\Profiles\defaultProfile\pkcs11.txt

My issue was on Mac. Not sure if this works on WIndows.

Here: \Users\''userid''\AppData\Roaming\Thunderbird\Profiles\''defaultProfile''\pkcs11.txt My issue was on Mac. Not sure if this works on WIndows.

Okulungisiwe ngu Mark Foley

Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
emmryss 0 izisombululo 7 izimpendulo
Kuphostiwe

Tried deleting that file but still have the same problem.

Tried deleting that file but still have the same problem.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
sfhowes
  • Top 10 Contributor
1438 izisombululo 6814 izimpendulo
Kuphostiwe

emmryss said

Tried deleting that file but still have the same problem.

Can you give more details of your problem? The original question is to do with profiles copied between Linux and Windows. If your passwords aren't being saved, check if you have a password manager operating as part of a security program.

''emmryss [[#answer-1239111|said]]'' <blockquote> Tried deleting that file but still have the same problem. </blockquote> Can you give more details of your problem? The original question is to do with profiles copied between Linux and Windows. If your passwords aren't being saved, check if you have a password manager operating as part of a security program.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.