Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Attachments won't open - permanently defaulted to save attachments

  • 9 uphendule
  • 2 zinale nkinga
  • 1072 views
  • Igcine ukuphendulwa ngu Sloeberry

more options

Windows 10. Thunderbird 60.5.2

Following the recent update I cannot open attachments of any kind. Either left double click to open or right click to open through menu produces the 'save' dialogue box. I am then prompted to save the file and would have to navigate to the file in order to open it. In options>attachments there is no option to set the default to 'open with' for handling attachments, this is missing completely. There is only an option to save to a default location or ask where to save each time. I have tried in safe mode. I have physically made no changes to any software/system elsewhere on my pc but of course there may have been a few auto updates somewhere. It's baffling and it's a deal breaker for me if I can't solve it.

All Replies (9)

more options
In options>attachments there is no option to set the default to 'open with' for handling attachments, this is missing completely.

See if this article helps. http://kb.mozillazine.org/Actions_for_attachment_file_types#Unexpected_handling_of_certain_attachments

more options

Thanks for the link, lots of useful info in there and I worked my way through. I deleted the mimeTypes.rdf file and that made no difference. I then returned it and edited it with some success. I can now open some attachments (tried .doc and jpeg files work). But I still have the problem with how pdfs are handled. The default is to save these. In the options>attachments settings, there is still no option to change how pdfs are handled, all other attachment types have options (drop down menu offering save as, always ask, delete action etc). Sp, partially solved but pdf handling options still frozen out.....

more options

Delete the entry for PDFs. Then double-click on a PDF attachment in a message you received.

Do you actually have Acrobat Reader installed?

more options

Thanks for taking the time to reply. Perhaps I didn't spell things out properly. Nothing can be done with the pdf entry, whilst the other attachment types now have various options (small arrow to the right hand side as in image below giving options save as/open with/delete action) the pdf entry is frozen out. nothing doing with it. That's the actual problem I'm trying to find a solution to. Editing the mimetypes file freed up the other attachment types but pdfs are still stuck in some sort of default 'save as' condition. yes I do have Reader installed, I have the full Adobe Acrobat suite.

more options

What happens when you select the entry for PDFs, and hit the Del key?

more options

I haven't solved the problem but have found a solution - I just rolled back to a couple of releases earlier and hey presto! - everything works as it should do. Clearly some sort of bug or incompatibility with my setup in the latest iteration. Thanks for trying though - no wiser to what the actual problem was.

more options

Having tried to delete using your earlier suggestion (hit delete button which is an obvious possibility that I hadn't tried) that didn't work either. Roll back is fine. No need for me to ditch Thunderbird - thankfully as it works a treat for me.

more options

I would still like to know why. Did you try Thunderbird in safe mode Windows key + R Type Thunderbird -safemode and press enter.

I find lots of the weirder issues are caused by only partially compatible add-ons that continue to be installed after an update. safe mode offers a way to test the theory (continue with add-ons disabled) without making permanent changes.

more options

Safe mode yielded nothing (see my first post). I have very few add-ons anyway. It would have been good to find out why the problem occurred as it may occur again - but at least I know that a roll back is practical.