Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Since the last two weeks FireFox is very slow, doen't let me access web site ect. why?

  • 6 uphendule
  • 1 inale nkinga
  • 66 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I have uninstalled two times but has not fixed the problem. This happened suddenly without me doing anything.

Isisombululo esikhethiwe

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Hello, If you are on window try to restore your computer to the earlier time. search rstrui.exe Click on it and follow the instructions on the screen. Hope this help

more options

Please explain the problem in detail. What happens? What is the exact error messages?

more options

Well i don't really now what to say. It is like the program is not running. Flash doesn't work also the radio station i listen to just stop working suddenly. But you tube works fin. It is just frustrating. Don't know what is happening

more options

refesh button fixes a lot of firefox issues, thats the first thing itry whenany firefox issue starts. may work for you,

more options

Hello, It is possible to have problems due to Flash Plugin Flash as technology will be retired from the web at the end of 2020 But until then you can use it type about:addons in your address bar click on Plugins tab It's flash here? If it is is Always Activate, Never activate, or Ask to Activate? Any help? Have a nice day!

Okulungisiwe ngu AnnaSycamore

more options

Isisombululo Esikhethiwe

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?