Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox Doesn't Ask Where To Save Downloads

  • 3 uphendule
  • 2 zinale nkinga
  • 395 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Removed by OP

Okulungisiwe ngu KenB67

Isisombululo esikhethiwe

You should never just download an EXE and run it without scanning it first for problems. Trusted sites are okay, but others . . . . . . . .

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Well ... I removed the OP because I think I've got it as sorted as I can. Although the OP is gone it did say I tried safe mode.

I ended up hosing everything Mozilla and starting out fresh ... all AppData and Program files ... gone (saved my bookmarks though).

On 50.0.2 I noticed that when FF Options is set to "always ask me where to save files" ... that there are actually 2 different popups used to save a file. For .exe files the option is just "Save" ... for files that are not .exe the options are "Open" and "Save" ... and that's the one I'm used to seeing ... the other one was throwing me for a loop.

After thinkin' about it ... makes no sense to open an exe without saving it ... could be dangerous too ... so the 2 different popups make sense. I prolly got all caught up in my underwear and couldn't figure out what was going on so I thought something was wrong. I'm reinstalling Windows 10 and all my programs ... of which number around 200 ... most music production, virtual instrument and recording programs. Getting punchy as hell spending long ours getting the work done.

Thanks anyhow!

Ken

more options

Isisombululo Esikhethiwe

You should never just download an EXE and run it without scanning it first for problems. Trusted sites are okay, but others . . . . . . . .