X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Force firefox to use spellcheck with a certain site

Kuphostiwe

My FF spellcheck works just fine, for almost all sites. But there is one site in particular (requires a login; it is a Moodle learning management system online class page) that must tell my browser not to use spellcheck on it.

Is there a script or about:config command I can use, to get FF to ignore this request, and give me spellcheck?

My FF spellcheck works just fine, for almost all sites. But there is one site in particular (requires a login; it is a Moodle learning management system online class page) that must tell my browser not to use spellcheck on it. Is there a script or about:config command I can use, to get FF to ignore this request, and give me spellcheck?

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

Umnikazi wombuzo

FWIW, this is not strictly speaking, a FF problem. I just logged in with another browser, and had the same problem. I'm just hoping someone has a script or command in about:config that I can use to override that site preference.

FWIW, this is not strictly speaking, a FF problem. I just logged in with another browser, and had the same problem. I'm just hoping someone has a script or command in about:config that I can use to override that site preference.
FredMcD
  • Top 10 Contributor
4245 izisombululo 59390 izimpendulo
Kuphostiwe

What is your computer system and Firefox?


Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.


If it still does not work, you may need an add-on to bypass the problem.

Can you post a public link that we can check out?

What is your computer system and Firefox? ---------- Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. Type: '''layout.spellcheckDefault''' Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes. Also, check the '''spellchecker.dictionary''' entry. ---------- If it still does not work, you may need an add-on to bypass the problem. Can you post a public link that we can check out?

Umnikazi wombuzo

spellcheck was set to default. Changing it to 2 didn't work. Dictionary was set up to work, as well.

I'm on Windows 10 and FDE, but I'm pretty sure this is version independent, as I have used beta and release as well, and don't remember the last time this page worked, if ever.

Sorry, but you need to be registered for a particular class to log in and start typing into any field where spellcheck should be working.

spellcheck was set to default. Changing it to 2 didn't work. Dictionary was set up to work, as well. I'm on Windows 10 and FDE, but I'm pretty sure this is version independent, as I have used beta and release as well, and don't remember the last time this page worked, if ever. Sorry, but you need to be registered for a particular class to log in and start typing into any field where spellcheck should be working.
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 izisombululo 40134 izimpendulo
Kuphostiwe

Right-click in the textarea box where to want the Firefox Spellcheck to work and take a screenshot of the contextual menu.


See this support article. How do I create a screenshot of my problem? It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB.

Then use the Browse .... button below the Post a Reply text box to upload the screenshot.

Right-click in the textarea box where to want the Firefox Spellcheck to work and take a screenshot of the contextual menu. See this support article. [https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem How do I create a screenshot of my problem?] It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB. Then use the '''Browse ....''' button below the '''''Post a Reply''''' text box to upload the screenshot.

Umnikazi wombuzo

Posted it here. FWIW, we can't use other things, like pasting from the context menu, either. We have to use the keyboard, and hten we can do that.

Posted it here. FWIW, we can't use other things, like pasting from the context menu, either. We have to use the keyboard, and hten we can do that.
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 izisombululo 40134 izimpendulo
Kuphostiwe

Looks like a "rich text area" box that overrides the Firefox context menu and inserts its own context menu.

That ABC to the right of B I U makes it appear that the "rich text" spell check is turned off. Is that you intent to have that turned off? Or maybe it can't be activated?

To get the Firefox contextual menu activated in that rich text area type about:config in the URL bar and hit Enter. Paste this pref name in the Search filed at the top to filter to this pref.

dom.event.contextmenu.enabled

Double-click that pref to toggle it to false - then Restart Firefox.


dom.event.contextmenu.enabled Determines whether the oncontextmenu event can be caught by non-chrome JavaScript (e.g., in an anti-right-click script). True (default): the opposite of below. False: Webpages will not be able to affect the context menu event, thus allowing to access the context menu all the time.

Looks like a "rich text area" box that overrides the Firefox context menu and inserts its own context menu. That '''<s>'''ABC'''</s>''' to the right of '''B'' I '' U''' makes it appear that the "rich text" spell check is turned off. Is that you intent to have that turned off? Or maybe it can't be activated? To get the Firefox contextual menu activated in that rich text area type '''about:config''' in the URL bar and hit Enter. Paste this pref name in the Search filed at the top to filter to this pref. '''dom.event.contextmenu.enabled''' Double-click that pref to toggle it to '''''false''''' - then Restart Firefox. -------------- dom.event.contextmenu.enabled Determines whether the oncontextmenu event can be caught by non-chrome JavaScript (e.g., in an anti-right-click script). True (default): the opposite of below. False: Webpages will not be able to affect the context menu event, thus allowing to access the context menu all the time.

Umnikazi wombuzo

Sorry, Ed, tried that about:config but it didn't work. I made sure to log out, restart after I had set it to false. Still doesn't work.

Sorry, Ed, tried that about:config but it didn't work. I made sure to log out, restart after I had set it to false. Still doesn't work.

Umnikazi wombuzo

Just re-read your reply.

That strikethrough the abc letters that you were referring to is not for rich text, but is simply a command to strike a line through the text.

Just re-read your reply. That strikethrough the abc letters that you were referring to is not for rich text, but is simply a command to strike a line through the text.

Umnikazi wombuzo

FWIW, there is on the bottom row, far right, an ABC check mark box. If I click on that, I can turn on spell check for what is already there, but if I start typing new material, it will not check the new material, and I have to re-enable it. Strange.

FWIW, there is on the bottom row, far right, an ABC check mark box. If I click on that, I can turn on spell check for what is already there, but if I start typing new material, it will not check the new material, and I have to re-enable it. Strange.

Okulungisiwe ngu paulri

the-edmeister
  • Top 25 Contributor
  • Moderator
5397 izisombululo 40134 izimpendulo
Kuphostiwe

Whoops! I didn't realize that was for "strike-over" for the message being typed; I am guilty of having a "mind fart" in public (silent and not "deadly").

I'm out of ideas now. It's been awhile since I have used a "rich text area" box like that, my webmail has /had it, but I switched all my webmail account prefs to use "text only" - I have grown to hate HTML email messages over the years.

Doesn't Moodle have a community support fora, where Moodle users can help other users?

Whoops! I didn't realize that was for "strike-over" for the message being typed; I am guilty of having a "mind fart" in public (silent and not "deadly"). I'm out of ideas now. It's been awhile since I have used a "rich text area" box like that, my webmail has /had it, but I switched all my webmail account prefs to use "text only" - I have grown to hate HTML email messages over the years. Doesn't Moodle have a community support fora, where Moodle users can help other users?

Umnikazi wombuzo

I'll look for one. Thanks for your time, regardless.

I'll look for one. Thanks for your time, regardless.
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157849 izimpendulo
Kuphostiwe

Do you see a spellcheck="false" attribute if you right-click that edit area?

Do you see a spellcheck="false" attribute if you right-click that edit area?

Umnikazi wombuzo

cor-el said

Do you see a spellcheck="false" attribute if you right-click that edit area?

No, I don't---if you meant in the context menu itself.

I posted in a Moodle forum, but didn't get a reply.

''cor-el [[#answer-880130|said]]'' <blockquote> Do you see a spellcheck="false" attribute if you right-click that edit area? </blockquote> No, I don't---if you meant in the context menu itself. I posted in a Moodle forum, but didn't get a reply.
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157849 izimpendulo
Kuphostiwe

Sorry that should have been to open the Inspector via the right-click context menu and check the HTML code of that element. You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools > Web Developer) with this element selected.

Sorry that should have been to open the Inspector via the right-click context menu and check the HTML code of that element. You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools > Web Developer) with this element selected. *https://developer.mozilla.org/Tools/Page_Inspector

Umnikazi wombuzo

I found this after searching for "spell":

<body id="tinymce" class="mceContentBody " onload="window.parent.tinyMCE.get('id_message').onLoad.dispatch();" spellcheck="false" dir="ltr" contenteditable="true">



</body>

So what do I do now?

I found this after searching for "spell": <body id="tinymce" class="mceContentBody " onload="window.parent.tinyMCE.get('id_message').onLoad.dispatch();" spellcheck="false" dir="ltr" contenteditable="true"><p><br></p><p><br></p></body> So what do I do now?
FredMcD
  • Top 10 Contributor
4245 izisombululo 59390 izimpendulo
Kuphostiwe

On that last line, change " spellcheck="false" to " spellcheck="true"

On that last line, change " spellcheck="false" to " spellcheck="true"

Umnikazi wombuzo

I can enter that in the inspector. But this happens in many different web pages in this domain for me. Every time I open up a reply field to type something in, I am going to have to make that change in my own browser's inspector? Or is there something I'm missing?

I can enter that in the inspector. But this happens in many different web pages in this domain for me. Every time I open up a reply field to type something in, I am going to have to make that change in my own browser's inspector? Or is there something I'm missing?
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157849 izimpendulo
Kuphostiwe

The web page uses the tinyMCE in a content editable DIV container (contenteditable="true") and indeed disables the built-in Firefox spelling checker as you can see by the presence of spellcheck="false".

Does if has effect if you remove this attribute by editing the page code?

  • Right-click this element in the Inspector: Edit as HTML
The web page uses the tinyMCE in a content editable DIV container (contenteditable="true") and indeed disables the built-in Firefox spelling checker as you can see by the presence of spellcheck="false". Does if has effect if you remove this attribute by editing the page code? *Right-click this element in the Inspector: Edit as HTML

Umnikazi wombuzo

Yes, when I edit as HTML, I can change teh attribute to true. And in that field, I get spellcheck.

But this is only one possible field. Whenver I click reply to any other post, the spellcheck doesn't work.

Is there some script or css sheet or something that I can do, that would only work on this site--but would still work, throughout this entire domain? Doing all this for every single field I want to type in, would be overkill.

Yes, when I edit as HTML, I can change teh attribute to true. And in that field, I get spellcheck. But this is only one possible field. Whenver I click reply to any other post, the spellcheck doesn't work. Is there some script or css sheet or something that I can do, that would only work on this site--but would still work, throughout this entire domain? Doing all this for every single field I want to type in, would be overkill.
cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157849 izimpendulo
Kuphostiwe

Does either of these JavaScript codes work in the Web Console or as a bookmarklet?

javascript:void(document.querySelector(".mceContentBody").setAttribute("spellcheck", "true"));
javascript:void(document.querySelector("[contenteditable=\"true\"]").setAttribute("spellcheck", "true"));
Does either of these JavaScript codes work in the Web Console or as a bookmarklet? <pre><nowiki>javascript:void(document.querySelector(".mceContentBody").setAttribute("spellcheck", "true"));</nowiki></pre> <pre><nowiki>javascript:void(document.querySelector("[contenteditable=\"true\"]").setAttribute("spellcheck", "true"));</nowiki></pre>