Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Icons replaced with boxes/letters, usual fixes don't work

  • 38 uphendule
  • 1 inale nkinga
  • 235 views
  • Igcine ukuphendulwa ngu jscher2000

more options

I have the usual "Icons replaced with boxes or letters" (or tomshardware for example, the Toms Hardware logo is replaced with "t H") but none of the solutions I've found have worked. I've tried Firefox Refresh, clearing cache/cookies (also with CCleaner), Checking gfx.downloadable_fonts.enable, making sure Firefox is set to download custom fonts.

This happened once before, and it just went away. Then it happened again, and a Refresh fixed it for a little bit. Now it's back, stubborn as ever. It's happening on every site that has special icons (e.g., YouTube's like/dislike buttons, though as I was writing this the like/dislike buttons came back). It's also affected profile pictures on Tom's Hardware, not showing them either.

Any help is appreciated. :) (I can't upload images, it just stalls. Let me know if I need to post them through Dropbox or similar)

Okulungisiwe ngu Commander-Matt

Isisombululo esikhethiwe

Basically removing prefs.js by renaming it or by using Refresh was successful, and nothing else was. But the effect didn't last. And one of the few interesting differences between the working prefs.js and the nonworking one that appears later is regarding your graphics card driver software being a problem.

My guess is that Firefox is taking some time to discover that it doesn't like your graphics card driver and once it figures that out again, that discovery leads to a change in behavior which interferes with downloadable fonts. Seems strange because it was okay up to that point.

The following Reddit seems very similar (same error message for icon font with hardware acceleration disabled):

https://www.reddit.com/r/firefox/comments/3uszgf/firefox_did_it_again_font_awesome_not_working/

I don't know why you have this problem on Windows 10 and I haven't heard of it before. Maybe try bypassing the graphics card blockage with this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx and pause while the list is filtered

(3) Double-click the gfx.direct2d.force-enabled preference to switch it from false to true -- this probably requires a restart to take effect

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (18)

more options

What security software do you have?

more options

jscher2000 said

I don't see any font-related differences. I'm not sure what this is: user_pref("gfx.blacklist.suggested-driver-version", "15.2010.1151.0"); but in the Question Details > More System Details next to your original post it says: direct2DEnabledMessage: [u'tryNewerDriver', u'15.2010.1151.0'] This article suggests how to update if there are known problems with your current graphics card driver software: Upgrade your graphics drivers to use hardware acceleration and WebGL.

I've been holding off updating to AMD's bleeding edge Radeon Crimson drivers, as I've had issues with other things with them installed (haven't been able to test their latest beta version though, I will soon). At the moment I have CCC 15.7. I'll get 15.7.1 later tonight and see if that fixes anything.

cor-el said

What security software do you have?

AVG 2016.0.7227

more options

Did you already try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen)?

more options

cor-el said

Did you already try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen)?

I have not. At the moment everything is normal. Should I try Safe Mode with network support if fonts turn into hex/letters?

more options

If it is working with the current profile then there is no need to boot in Windows Safe Mode.

more options

cor-el said

If it is working with the current profile then there is no need to boot in Windows Safe Mode.

The problem came back on its own. I tried safe mode with networking, didn't help. Also tried clearing cookies, cache, history, etc., and that didn't solve the problem either. Anything I should try before removing the prefs.js again?

more options

Did you make any changes to font settings in Firefox?

The prefs.js file you uploaded doesn't seem to contain any specific prefs that might explain this issue. Maybe first try to rename the content-prefs.sqlite and permissions.sqlite files to see if that has effect.

more options

cor-el said

Did you make any changes to font settings in Firefox? The prefs.js file you uploaded doesn't seem to contain any specific prefs that might explain this issue. Maybe first try to rename the content-prefs.sqlite and permissions.sqlite files to see if that has effect.

I haven't made any changes to font settings. I haven't added my preferred theme, either. I will rename the content-prefs.sqlite and permissions,sqlite files. Should I rename prefs.js?

more options

cor-el said

Did you make any changes to font settings in Firefox? The prefs.js file you uploaded doesn't seem to contain any specific prefs that might explain this issue. Maybe first try to rename the content-prefs.sqlite and permissions.sqlite files to see if that has effect.

I renamed content-prefs.sqlite and permissions.sqlite, problem persists.

Edit: Renaming prefs.js fixed the issue again. Not sure why, I never changed any settings. Edit #2: Firefox crashed shortly the first edit (whole computer was stuttered, I don't think it was directly Firefox's fault?), problem has returned. So... I guess a restart does cause the problem to return? Going to rename prefs.js again and run a Malwarebytes scan next time I'm away from my computer.

Okulungisiwe ngu Commander-Matt

more options

The only settings in prefs.js that could affect this is would be gfx.downloadable_fonts.enabled and possibly browser.display.use_document_fonts

more options

cor-el said

The only settings in prefs.js that could affect this is would be gfx.downloadable_fonts.enabled and possibly browser.display.use_document_fonts

Firefox crashed again (was on Netflix and Silverlight was outdated, so I updated Silverlight. Hoping updating Silverlight fixes the crashes) and the problem has returned. gfx.downloadable_fonts.enabled is set to true, and browser.display.use_document_fonts is set to 1. Is there anything that would override font settings all together? Allow pages to choose their own font is checked in Options > Content > Advanced as well.

I've also noticed that on some sites (not all), the text is off from what it normally is.

more options

Isisombululo Esikhethiwe

Basically removing prefs.js by renaming it or by using Refresh was successful, and nothing else was. But the effect didn't last. And one of the few interesting differences between the working prefs.js and the nonworking one that appears later is regarding your graphics card driver software being a problem.

My guess is that Firefox is taking some time to discover that it doesn't like your graphics card driver and once it figures that out again, that discovery leads to a change in behavior which interferes with downloadable fonts. Seems strange because it was okay up to that point.

The following Reddit seems very similar (same error message for icon font with hardware acceleration disabled):

https://www.reddit.com/r/firefox/comments/3uszgf/firefox_did_it_again_font_awesome_not_working/

I don't know why you have this problem on Windows 10 and I haven't heard of it before. Maybe try bypassing the graphics card blockage with this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx and pause while the list is filtered

(3) Double-click the gfx.direct2d.force-enabled preference to switch it from false to true -- this probably requires a restart to take effect

more options

jscher2000 said

Basically removing prefs.js by renaming it or by using Refresh was successful, and nothing else was. But the effect didn't last. And one of the few interesting differences between the working prefs.js and the nonworking one that appears later is regarding your graphics card driver software being a problem. My guess is that Firefox is taking some time to discover that it doesn't like your graphics card driver and once it figures that out again, that discovery leads to a change in behavior which interferes with downloadable fonts. Seems strange because it was okay up to that point. The following Reddit seems very similar (same error message for icon font with hardware acceleration disabled): https://www.reddit.com/r/firefox/comments/3uszgf/firefox_did_it_again_font_awesome_not_working/ I don't know why you have this problem on Windows 10 and I haven't heard of it before. Maybe try bypassing the graphics card blockage with this change: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste gfx and pause while the list is filtered (3) Double-click the gfx.direct2d.force-enabled preference to switch it from false to true -- this probably requires a restart to take effect

Doing this fixed the problem (without renaming prefs.js). Just to be safe, I restarted Firefox multiple times, and the problem has stayed away.

Maybe Firefox doesn't like that I'm not running the bleeding edge driver?

more options

Hopefully it sticks!

I think there is a glitch with this driver. In your Question Details > More System Details there is an inconsistency which suggests some internal confusion:

direct2DEnabled: False direct2DEnabledMessage: [u'tryNewerDriver', u'15.2010.1151.0'] directWriteEnabled: False numAcceleratedWindows: 1 numTotalWindows: 1

I'm pretty sure if direct2d is disabled, numAcceleratedWindows should be zero. I'm not sure why your Firefox shows this odd data.

more options

jscher2000 said

Hopefully it sticks! I think there is a glitch with this driver. In your Question Details > More System Details there is an inconsistency which suggests some internal confusion: direct2DEnabled: False direct2DEnabledMessage: [u'tryNewerDriver', u'15.2010.1151.0'] directWriteEnabled: False numAcceleratedWindows: 1 numTotalWindows: 1 I'm pretty sure if direct2d is disabled, numAcceleratedWindows should be zero. I'm not sure why your Firefox shows this odd data.

I'll update to the bleeding edge driver once AMD polishes it and releases the next version. I have unrelated problems with it, so I've been holding off updating to it.

Should I make a bug report about the internal confusion?

more options

Commander-Matt said

Should I make a bug report about the internal confusion?

Sure, that would be great. I would definitely mention the text of the errors from the console as an important clue.

more options

jscher2000 said

Commander-Matt said
Should I make a bug report about the internal confusion?

Sure, that would be great. I would definitely mention the text of the errors from the console as an important clue.

Is BugZilla the only bug reporting location? It's very hard to fill out the BugZilla form.

more options

Commander-Matt said

Is BugZilla the only bug reporting location? It's very hard to fill out the BugZilla form.

For this, I don't think there is another place to file. (Some parts of Firefox are debugged on Github.)

I wouldn't worry about fields such as the component or module, if that's where things are getting complicated. Someone who knows about the graphics bits will probably correct that anyway. Mainly there are a few big boxes to fill in.

  1. 1
  2. 2